Kia Owners Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi all,

now that I have lived with my Sporty for a week n a bit I am realising things I didnt notice on the testdrive
.

My Sporty is 7 years old and has around 90k on the clock.

I was wondering if any other guys here have this ticking sound when the car is idling? Mines so loud that it almost sounds like I'm driving a diesel powered car and not a petrol one
.

Anyone know if this is normal?

Here in Germany if anything is wrong with the car, (other than your normal wear and tear like clutch, breaks...) in the first 6 months, the dealership need to repair/replace the faulty item...
I already had the clutch replaced as on the testdrive it seemed very hard to depress the pedal... its great now...but this sound is making me think that perhaps sommet aint right with the engine...and if thats the case I would take it back for them to look at and repair...

Any infos much appreciated.

Thanks
 

·
Registered
Joined
·
717 Posts
I've the Cee'D 1.6 GDI which has less miles on the engine but I've found the oil level really makes a difference to the engine sound. I guess we need to remember it's a direct injection engine so will be a louder combined with a chain cam rather than a belt.

However mine's nearly silent in the car at tick over but at 5000rpm and above under acceleration can sound rough. Edited by: monkeygibber
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Hi,Thanks for your replies so far...

When I bought my sporty the Garage put it through a Major Service, so Oil Level is fine.

The ticking Sound I have is when the engine is cold and warm and can be heard when stood at the lights.
I first thought well ist only a small engine... but then found others who also complaining about their car sounding like a diesel...
I'm starting to think that I might just sell the car on, as I'm finding the boot rather small and also my other half finds the passenger seat uncomfortable due to the possition of the headrest...
 

·
Registered
Joined
·
28 Posts
Well,
not many more replies.
I have had the car now almost 2 years and it seems to still be running ok.
The ticking noise I have come to get used to. The dealership where I bought the car took a look at it and said all is ok and put the blame on the high pressure fuel pump...
So, driven about 20 odd K in the 2 years and the only issue I had is that on my last trip my oil level light came on...now I had driven a few KM since Christmas, when I checked the oil level before driving over to Blighty, and it was fine... think I should have checked again once I got back ;)
Anywho, after the switch on switch off oil lamp reset it has remained off.
Will see how many KMs or years I still get out of my Sporty.
I deffo dont regret getting it.
rgds
Rob
 
1 - 5 of 5 Posts
Top