Kia Owners Club Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all. I'm getting an error on dash saying check rear lights and when I've had a look it seems the whole row of rear lights are off. I've attempted to check the fuse but not 100% sure what is the correct one, but none seem to be blown. The middle brake light above the rear window still works as well as the bottom indicators.

Has anyone came across this before or any ideas on a fix?

Thanks in advance. Picture attached for reference.

11335
 

·
Registered
Joined
·
109 Posts
Yeah that's right.


S
To me that feels like a fuse issue but i am no expert. That would be my first line of enquiry. Re-check all of them. If the Sporty is like many others cars i have had, it will have two banks of fuses. One in car and one under bonnet.
Have a read of the manual to see if you can whittle down the fuse location.

Oh, and the LED break light strip is not the same fuse circuit as the normal bulbs so that still working is not a surprise.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Upon further inspection the rear lights are working its just the rear brake lights. I've had a good look through the manual but cant seem to see any reference to rear brake lights fuse, only things like stop lamp but those fuses are good. Would it be named anything else?
 

·
Registered
2017 GT Line S 1.6 Petrol AWD
Joined
·
209 Posts
If fuses check out ok then it could be something else, possibly wiring harness where it goes into tailgate.
I had a jag that the wiring loom failed where it entered the boot.
 

·
Registered
Joined
·
151 Posts
Upon further inspection the rear lights are working its just the rear brake lights. I've had a good look through the manual but cant seem to see any reference to rear brake lights fuse, only things like stop lamp but those fuses are good. Would it be named anything else?
Hi have you checked the bulbs if the high level brake light is working so the brake light switch is working so check the bulbs.
 

·
Registered
66 plate Sportage KX4
Joined
·
214 Posts
If the high level brake light is working it’s unlikely to be a fuse as you’d expect the others to come off the same one.
 

·
Registered
2021MY Ceed GT Line S
Joined
·
44 Posts
Stop lamp on these runs off an independent 7.5 amp fuse, can't for the life of me remember the fuse rating / position for rear light cluster. Believe it runs independently of the front lights mind you.

It's likely to be a dual purpose fuse; rear light cluster AND xxxxx ! Have you checked the manual for the fuse diagram?
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top