Kia Owners Club Forum banner

1 - 7 of 7 Posts

Registered
Joined
4 Posts
Discussion Starter #1
Need your help!! 馃槺

2011 Kia Sportage 2.0 AWD

While driving i hit gas pedal and car shakes slightly while driving at 60mph, stops shakes when I took my foot off the gas!
In the last month, I thought is my Flywheels and clutch problems, so I had it replaced and costed me 拢1800, however, still shakes at 60mph!! So I thought I should have my car fully serviced, costed me 拢300, guess what, my car still shakes at 60mph while I pressed the gas pedal, stopped shakes when I let off the pedal. My steering wheel is smooth all the way, my car is smooth till all the way to 60mph.
So I just had my wheels balanced and tracking today, and guess what, still shakes at 60mph!! The mechanics from garages couldn鈥檛 find any problems but it鈥檚 driving me totally insane!!!
There鈥檚 is something wrong with my car, one small thing and what鈥檚 is it??
The mechanics said my driveshaft looks ok....! I鈥檓 stuck. Any advice guys?
 

Registered
Joined
3,316 Posts
Have you tried driving at 60 in a different gear? Does it make any difference? What happens if you drive faster than 60? What happens if you put it into neutral?
 

Registered
Joined
1,577 Posts
There鈥檚 is something wrong with my car, one small thing and what鈥檚 is it??
At distance, it's always difficult to pinpoint the fault but I suspect you may already have had the answer on post #2. Fuel starvation, very possibly from a fuel filter cannot be ruled out.
 

Registered
Joined
4 Posts
Discussion Starter #6
Have you tried driving at 60 in a different gear? Does it make any difference? What happens if you drive faster than 60? What happens if you put it into neutral?
Yes I have driven on 5th gear till is hit 60mph, that鈥檚 when the engine start to shake when pressing the gas pedal, when I let go the gas pedal at 60mph, everything gone smooth! I鈥檝e tried in neutral during at 60mph, still smooth. I鈥檓 still scratching my head! 馃槀
 

Registered
Joined
4 Posts
Discussion Starter #7
Forgot to add, when my car went over 70mph, everything is all smooth, and when my car go from 0 to 60mph, everything is smooth till it hit 60mph, my engine shakes and stopped shakes when my car go at 70mph. That鈥檚 when I鈥檓 using the gas pedal. I鈥檓 still scratching my head! 馃馃槀
 
1 - 7 of 7 Posts
Top