Kia Owners Club Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
Last week I had the engine management warning light come on, just as I hit the bad weather on my northbound commute. A while later the same day it went out. I decided to call in at my "local" Kia dealer, but as it had gone out, they said it was probably a glitch. Ironically, after leaving there it came back on again so I went back and asked them to have a check. The diagnostics came back with "engine inlet manifold valves sticking". I'm not sure what this means, but decided to arrange to have someone with suitable equipment a bit closer to home to look at it (when the ice has gone from their access road), however, the light has just gone out again. Not sure what or where the problem is, but it still drives OK.


Maybe it doesn't like the cold
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #3 ·
Since my post on this, I've had the light come on and go out again several times. It can remain on for one day or four or five; and then go out for two to three weeks. I'm not sure whether it's worth the expense of a dealer investigation for a mechanical problem or whether there's an intermittent electronic gremlin. Any ideas.
 

·
Registered
Joined
·
543 Posts
Have similar in my picanto engine management light flashes on hard acceleration usally quite often and just ignored it does yours come on like this ? i'f so will be fine because mines been flicking for 2yrs with no issue and put down to electronic issue .
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #5 ·
No, when it's come on, or rather not gone out has been when I've started the car up. Last night eg after about 300 miles, I stopped for a coffee and when I restarted the car the light stayed on. Some subsequent starts today had the light go out for a second and then come on again. Usually after a few days it will then go out for a few weeks.
 

·
Registered
Joined
·
682 Posts
Surely if a fault code has been registered it should be in the ECU memory?
Sounds like some item don't like the cold weather? or bad electrical connection?



Bob
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #7 ·
That's what I'm thinking. Last info I had was "inlet manifold flaps sticking". Maybe they stick, then unstick.... I doubt it though. Sometimes the power seems low (car feels sluggish). But yesterday the light went out and stayed out.
 
1 - 7 of 7 Posts
Top