Kia Owners Club Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hi Everyone.


Today I went out and got myself a Sorento.




After looking at a few Sorento's over the last few weeks I finally found one

that ticked all the boxes.



I have now got an 04 XS auto model with all the toys on and a FSH so all should be good.



I had to drive it about 70 miles home and even got stuck on the M6 in the Friday afternoon

rush and it behaved perfectly.



Once I started playing with the radio I seem to have lost the volume control, after going

through the settings for start up volume and mute volume as soon as I turn the rotary

volume control it just goes straight to "0".

As a temporary measure I have upped the mute setting so I can hear it.



The Radio is a CD 735 X



Anyone any ideas ?????????



TelfordPaul
 

·
Registered
Joined
·
93 Posts
Nice 1 - Well done Paul -




Not sure about the vollume though my 2004 already had a after market radio fitted when Brought it and Ive since replaced that with one that has a proper IPod dock.






Just a thought its not in TA (Traffic Announcment)setting is it the volume for that can ussually be setseperatley



Martin
Edited by: UncleMart
 

·
Registered
Joined
·
887 Posts
Sounds like the VDO unit, bin it and buy something much better for next to nothing, terrible stereos, just a std single din fitting.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
Thank you for the info guys.


I have been trying to get some volume but to no avail so it looks like a

trip to halfords for a new stereo.



They have quoted me a total price including fitting of £178 for a JVC unit

that has a front USB port for a memory stick or MP3 player and Bluetooth

connection to my mobile phone. Sounds good to me..




Regards



TelfordPaul ( Proud owner of a Sorento XS Auto)
 
1 - 4 of 4 Posts
Top