Kia Owners Club Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,053 Posts
Discussion Starter #1
On my Rio CRDi, just after it got to about 22,000 miles I suddenly started getting a strange vibration coming through the clutch pedal. This seems to be related to engine revs, not from the clutch itself as far as I can tell. It's very noticeable when the engine is at 2,500 rpm and you put a bit of pressure on the pedal. It makes changing gear feel like you're forcing a damaged cable through it's sleeve, ienot asmooth action...even though when the car is in neutral the clutch slides up and down perfectly smoothly.


Yesterday it had its second service and the mechanic noticed it too. He also found that hegot the same with another Rio, so thought it was the same with all Rios.









I asked if anything could be dome about it and he said he'd contact Kia and see if this was a known problem and find out if there was a fix for it. He said this had been done for the Ceed model.



Has anyone else had this problem with their Rio?



During the service Iborrowed a Picanto and thatalso had a horribleclutch even though it had only done about 2000 miles (It pulled left too, lol!)
 

·
Registered
Joined
·
2,252 Posts
Is it not the clutch release bearing contacting the pressure plate spring vanes thats causing the slight vibration. I wonder if some of the vanes are not sitting correctly and what you get is a high point that is skiffing the release bearing. Not 100% on this one tho'
 

·
Registered
Joined
·
1,053 Posts
Discussion Starter #4
Hi Diddy, not sure, it probably is as you say, but the feeling you get when you push your foot down makes it feel like your pushing on a dodgy cable.The action isperfectly smooth when in neutral.
 
1 - 4 of 4 Posts
Top