Kia Owners Club Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,


Bought my Sorento XE diesel in November 2010. It is 3 years old (57plate) and has been fine until today.



Started and drove the car as normal, and had the ventilation on to warm the interior. After driving for about 30 minutes, felt the interior getting cooler, so increased the speed of the fan from slow to medium and increased the temperature.



This is when I found that the fan was not working, and also therefore the air flow direction and air-conditioning controls had failed too.



Checked the fuses and all appears okay, so gather will be a trip to the Kia dealer hopefully to rectify between now and Christmas.



I can't drive the vehicle like this without heating when it is -7C outside, and also the windscreen mists over due to poor ventilation.



Anyone out there can give me a pointer where to look, or know the possible cause and if I can easily rectify.



Thanking you in anticipation
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Yes, you were quite right. Not sure why it happened and replaced with spare fuse. Need to check if the rear wiper works too, but will make sure that I have anoher fuse first.


Looking at thefuse chart, was trying tofind the location of it, and my wife tellsme it is 10A! Stupid woman!!!


Thanks again for your prompt reply and getting me out of a hole, especially whilst it is so cold.


Have a good Christmas.


Andy
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Not sure if I did, but one problem I do have is that I drive two different vehicles, where the steering column controls are reversed. So therefore I may have operated the rear wiper control by mistake of which would have been the lights.


Anyway the rear wiper does work okay, and have now spare fuses incase it happens again. Nice to drive a 4-wheel drive car in theis weather - and been warm too again
 

·
Registered
Joined
·
66 Posts
The rear wiper arm gets frozen to its rest bracket, switch it on when it's frozen causes the fuse to blow which also cuts power to the heater blower. Make sure its free before switching on the rear wiper to avoid blowing the fuse.
10amp fuse in the drivers footwell, Number 12 on my fuse box.
2007 Manual XE.

The centre consul power socket in the trinket tray has it's fuse 30Amp in the engine compartment fuse box if anyone needs to find that one.

Colin
 
1 - 6 of 6 Posts
Top