Kia Owners Club Forum banner
1 - 20 of 27 Posts

Registered
Joined
4 Posts
Discussion Starter · #1 ·
After upgrading from the old UVO App to the new one, I log in to the new App using my Kia Account. I am then presented with a screen "Existing UVO Users - Find UVO Account" - it wants my UVO email and password. I cannot create a new UVO account, as the email address is already in use.

However, it does not recognise my password and there is no option to reset it!

Any ideas?
 

Registered
Joined
4 Posts
Discussion Starter · #4 ·
Yes I have a Kia Account - but actually, I needed to click on the first option "UVO Account" even though I didn't sign up to the UVO App until I had my car at the start of February!
 

Registered
Niro DL, 2020, UVO
Joined
133 Posts
Also here in Netherland no problems to log in into the new UVO Connect and run both parallel ...
 

Registered
Joined
39 Posts
This is my impression of the new UVO app:

Well, wouldn't it have been nice if someone had told me about this new version rather than me finding out by chance? Why is it not simply an update of the old UVO app, installed automatically on your phone? As for being an improvement, I remain to be convinced. The only thing I've seen so far is that the DTE shows separate values for electric and petrol (I have a PHEV), rather than just the total. But the DTE is STILL in km although my default unit is miles! I told the developers this was wrong 7 months ago - surely it is a simple fix? And why does it currently show battery level 0% when it showed 50% a few moments ago. The status also says 'not plugged in' when it is plugged in and 'scheduled charging off' when it's on (and I've even fetched the schedule and returned it to the car via the app.AND sat in the car to check it was still there).. The old UVO still shows this information correctly at the moment! The new app still won't open the doors if locked with the key. And where is the expected charging time info and 'my messages' which were in the old app? They were useful. So what have I gained, apart from more frustration? I hope they've done a better job on updating the infotainment update which I'm expecting next month.. The old one has enough quirks.
 

Super Moderator
Joined
9,436 Posts
This is my impression of the new UVO app:

Why is it not simply an update of the old UVO app, installed automatically on your phone?
The V2.0 is a totally different app. It is in the Native Google style, unlike the old one. As such it is not possible to simply update the old app. It has to be a whole new app.

Yes, it would have nice to have a heads up on it, but guess like many companies they do not want everyone downloading at the same time. As it can overload the servers that handle registration details. Leading to even more frustrations.
Also helps if there are any bugs.

No issue with open/close doors V2.0 never seems to have a problem, unlike the old one.

I would suggest deleting the old one off your phone. As it could cause conflicts. Even though I did run both for a few days, with no issues. But then mine is only a HEV and only thing I can do is open/shut doors.
 

Registered
Joined
39 Posts
The V2.0 is a totally different app. It is in the Native Google style, unlike the old one. As such it is not possible to simply update the old app. It has to be a whole new app.

Yes, it would have nice to have a heads up on it, but guess like many companies they do not want everyone downloading at the same time. As it can overload the servers that handle registration details. Leading to even more frustrations.
Also helps if there are any bugs.

No issue with open/close doors V2.0 never seems to have a problem, unlike the old one.

I would suggest deleting the old one off your phone. As it could cause conflicts. Even though I did run both for a few days, with no issues. But then mine is only a HEV and only thing I can do is open/shut doors.
Well my scheduled charge last night failed, so I had to charge this morning at 3 x the price. Not a good start. Trying again tonight.
 

Super Moderator
Joined
9,436 Posts
Well my scheduled charge last night failed, so I had to charge this morning at 3 x the price. Not a good start. Trying again tonight.
Is the New App fully linked into a profile on the car? Do not know if that will make any difference. Only likely to be a issue if you have the Purple software.

Is everything set in the app & car as it should, since the update? As I would have thought that the car setting would start the charging?
 

Registered
Joined
39 Posts
Is the New App fully linked into a profile on the car? Do not know if that will make any difference. Only likely to be a issue if you have the Purple software.

Is everything set in the app & car as it should, since the update? As I would have thought that the car setting would start the charging?
The scheduled charging failed again last night, despite the new app saying beforehand that the charging schedule was on. This morning, however, it said the schedule was off. All I did last night was plug the car in and check on the infotainment system that the charging was indeed scheduled and how long it would take. I never use the app to set the schedule as I had multiple problems with scheduled charging when I first got the car. That seemed to be over until the new app came along. Really frustrating.
I'm not sure what you mean by 'fully linked into a profile on the car'. All the car's details appeared on the app as before. There was obviously two way communication as I got messages yesterday about the doors being open and the manual charge being complete. What is Purple software?
 

Registered
Joined
39 Posts
There was obviously two way communication as I got messages yesterday about the doors being open
This brings me to another thing I hate about this app, both the old and new versions - the messages about the doors being unlocked. Being alerted to the doors being unlocked could be helpful if you're well away from the car, but not whilst you're in the process of unloading. We get multiple messages just whilst bringing the shopping inside the house. It should ideally be able to detect whether the key was close by the car, before sending these alerts but that's perhaps expecting too much from technology.
Then there's often the problem of delay in receiving alerts. For instance. a couple of weeks ago we took our bikes on the car and went cycling. Half an hour later I got an alert saying the doors were unlocked. This got me really worried, but in fact there was no issue. The problem was lack of a phone signal where we were cycling (I've been told UVO relies on the the Vodaphone network) and it had taken half an hour for the message to get through. And the message had of course been generated whilst we were unloading our bikes.
Working like this destroys all faith in the system.
 

Registered
2020 Kia E-Niro 4
Joined
251 Posts
I've not ventured into the UVO app in the three months since I got the car, can't say that I have missed any of it's functions, and seems like it might be as well to just give it a miss. I wonder if these sort of apps are a solution looking for a problem. A bit like keyless entry, I never had a problem pressing a button on a key fob, or even using a key come to that.
 

Super Moderator
Joined
9,436 Posts
I'm not sure what you mean by 'fully linked into a profile on the car'. All the cars details appeared on the app as before. There was obviously two way communication as I got messages yesterday about the doors being open and the manual charge being complete. What is Purple software?
If you do not know what the purple software then it is safe to assume that you have not had the 2021 map update installed. Which gives the display a purple colour scheme (Type 2) & only 2 widgets, rather then the 3 of the black/white software (Type 1).

It is only on the purple software that you get the option to set profiles for different drivers (2) & guest. So if you have the Type 1 software you do not have to worry.
I agree signal coverage is a issue with the sending on messages. But no matter which network they choose there will always be some area's that lack coverage.

Type 2 (purple software)
10798
 

Registered
Joined
39 Posts
If you do not know what the purple software then it is safe to assume that you have not had the 2021 map update installed. Which gives the display a purple colour scheme (Type 2) & only 2 widgets, rather then the 3 of the black/white software (Type 1).
No, I'm still on type 1, type 2 update planned for service next month. Didn't know it was purple :confused:
 

Registered
Joined
39 Posts
The scheduled charging failed again last night, despite the new app saying beforehand that the charging schedule was on. This morning, however, it said the schedule was off. All I did last night was plug the car in and check on the infotainment system that the charging was indeed scheduled and how long it would take. I never use the app to set the schedule as I had multiple problems with scheduled charging when I first got the car. That seemed to be over until the new app came along. Really frustrating.
Well, de-installed the new app yesterday and scheduled charging worked fine last night for the first time in three days!
 

Super Moderator
Joined
9,436 Posts
No, I'm still on type 1, type 2 update planned for service next month. Didn't know it was purple :confused:
Don't tell Kia. They think it's "Magenta" :eek: 馃槀

Glad you got the charging sorted. (y)
 

Registered
Joined
1,178 Posts
Just noticed that the new UVO Connect app is now reporting DTE in miles instead of km. I didn't change anything so I guess it's been fixed at the car or Kia end.


Sent from my iPad using Tapatalk
 

Registered
Joined
39 Posts
It says miles but it assumes the distance shown on the dash of the car is in km so multiples that figure by 0.621 to convert it to miles. At least it does for me. At the moment my dash shows a range of 424 miles including a full charge of 33 miles electric, whereas UVO connect says 263 miles with 20 miles electric. How stupid is that!
 

Registered
Joined
1,178 Posts
It says miles but it assumes the distance shown on the dash of the car is in km so multiples that figure by 0.621 to convert it to miles. At least it does for me. At the moment my dash shows a range of 424 miles including a full charge of 33 miles electric, whereas UVO connect says 263 miles with 20 miles electric. How stupid is that!
I don't have a hybrid so that issue doesn't affect me, it was simply that despite having miles set in Units it reported DTE in km, but that seems to have been magically fixed. Range on the dash and the App have always matched for me but the units were wrong in the app


Sent from my iPad using Tapatalk
 

Registered
Joined
39 Posts
I don't have a hybrid so that issue doesn't affect me, it was simply that despite having miles set in Units it reported DTE in km, but that seems to have been magically fixed. Range on the dash and the App have always matched for me but the units were wrong in the app


Sent from my iPad using Tapatalk
Interesting, my PHEV was like that, i.e. the figure on the dash matched that on the old UVO app except it said the figure was km instead of miles. I seem to remember the new UVO Connect was the same for a while then the update came and it all went haywire a few weeks ago.
Strange it should be model dependent - or maybe it's just my car? Hopefully some others on the forum will comment.
 
1 - 20 of 27 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top