Kia Owners Club Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi all!
Enjoying my new Sportage "3", activated Uvo Live, linked with the phone app etc etc ... all good, but from the phone Uvo app, in the map, I select a destination and hit "send to car" it says it successful but it nowhere to be found in the car infotainment system.
I went through every option under the "Map" and "Nav" .. POIs, Search ... nowhere
Any clues ?
 

·
Registered
Joined
·
280 Posts
All new MY21 Sportages sold in the UK are now compatible with Kia Sportages. Have to be careful here as MY20 models sold earlier this year are not.
 

·
Super Moderator
Joined
·
3,281 Posts
Hi all!
Enjoying my new Sportage "3", activated Uvo Live, linked with the phone app etc etc ... all good, but from the phone Uvo app, in the map, I select a destination and hit "send to car" it says it successful but it nowhere to be found in the car infotainment system.
I went through every option under the "Map" and "Nav" .. POIs, Search ... nowhere
Any clues ?
Don't know if this will help

And Kia's offering
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Don't know if this will help

And Kia's offering

Thanks, but the display doesnt look like the one in the video .. I think its a more recent version, where the icons are sort-of purple ... I should really paste a picture here :LOL:
I remember seeing a picture here somewhere, I'll try to find it, if not I'll take one of mine later and post it here
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Found one, this is how my panel looks, very my21-ish ... so I'd expect Uvo nav send to car to work ....

7762
 

·
Registered
Joined
·
60 Posts
Hi all!
Enjoying my new Sportage "3", activated Uvo Live, linked with the phone app etc etc ... all good, but from the phone Uvo app, in the map, I select a destination and hit "send to car" it says it successful but it nowhere to be found in the car infotainment system.
I went through every option under the "Map" and "Nav" .. POIs, Search ... nowhere
Any clues ?
I have exactly the same problem, and have yet to find a solution for it
 

·
Registered
Joined
·
14 Posts
I've tried sending destinations to the car via the UVO app and it's worked every time.
Must admit I use Android auto for sat Nov rather than the inbuilt one.
KIA really need to sort the tech out on this car, as it's spoiling what is otherwise a fantastic car.
 

·
Registered
Joined
·
60 Posts
I've tried sending destinations to the car via the UVO app and it's worked every time.
Must admit I use Android auto for sat Nov rather than the inbuilt one.
KIA really need to sort the tech out on this car, as it's spoiling what is otherwise a fantastic car.
i'm quite happy to accept that I've done something wrong setting it up, I just don't know what. Several functions say "available after account has been linked" but as far as I'm concerned it has been. Linked to what? How? It isn't very user friendly for resolving problems like this.
 

·
Registered
Joined
·
14 Posts
It's not the most intuitive app or system I've used. It's really frustrating to try and get to grips with, and they help available online is next to useless.🤦
 

·
Registered
Joined
·
5 Posts
Discussion Starter #11
I have the feeling your setup (and mine) is OK, and this is just software related. The app should know what your car system supports and hide the feature. The same way mine shows an empty petrol tank every time. Not didabled/grayed out, empty ... Thats just really bad software ... and Kia will probably soon realize that these days bad software can easily make or break a product.
And I could go on about crappy features of the app .... like trip summary .. useless .. you get distance and max speed ... when the car system calculated fuel consumption and loads of other stats ...Its just lazy software.

Hoping at least that as we have a MY21 infotainment, it can be upgraded/fixed soon (on my next servicing?)
 

·
Registered
Joined
·
60 Posts
I have the feeling your setup (and mine) is OK, and this is just software related. The app should know what your car system supports and hide the feature. The same way mine shows an empty petrol tank every time. Not didabled/grayed out, empty ... Thats just really bad software ... and Kia will probably soon realize that these days bad software can easily make or break a product.
And I could go on about crappy features of the app .... like trip summary .. useless .. you get distance and max speed ... when the car system calculated fuel consumption and loads of other stats ...Its just lazy software.

Hoping at least that as we have a MY21 infotainment, it can be upgraded/fixed soon (on my next servicing?)
Don't hold your breath but I think I've solved it (for me at least). I had downloaded the app and set up my account and logged in. I had activated the UVO app on the car and sync'd it with the car, but I had left out a vital step. I needed to link my UVO account to my Driver Profile. From the Home screen, select your profile , open it up and Edit your profile and there are the options for linking to your UVO account. Did that and everything that didn't work, including sending POIs to the car now works faultlessly. I hope this solved your issues too.
 

·
Premium Member
Joined
·
88 Posts
After finally getting mine to work with the help of Alan, I've sent some destinations 'successfully', Unlock and Lock and that's about it.

Not really sure what else the App does or supposed to do?
 

·
Premium Member
Joined
·
88 Posts
In fact, 'Unlock' doesn't unlock, more of Flashes twice....pause, flashes twice and that's it.......Doh! :rolleyes:
 

·
Registered
Joined
·
5 Posts
Discussion Starter #15
Awesome @Alanw47
You gave me hope ahahaha
So I deleted my "Driver" profile and re-created it and re-linked and its working now !!!
Sure .. petrol still shows empty .. but thats for another day :D

So in summary, you create the driver profile etc etc as you get your new car, then go to "Uvo" and activate the app/uvo (gets email/code etc), then go back to your driver profile and "link" which send another code to your phone. Note if it doesnt work with your phone use the full international number e.g. +44xxxxx
 

·
Super Moderator
Joined
·
3,281 Posts
Anyone fancy doing s "How to" set up UVO and posting it in the HOW TO section.

Will be a nice to know for many users as it seems to be a common issue.
 

·
Registered
Joined
·
888 Posts
Anyone fancy doing s "How to" set up UVO and posting it in the HOW TO section.

Will be a nice to know for many users as it seems to be a common issue.
There is a YouTube video which is a dealer working his way through the process step be step.
 
1 - 17 of 17 Posts
Top