Kia Owners Club Forum banner

1 - 8 of 8 Posts

Registered
Joined
1 Posts
Discussion Starter #1
Is anybody having problems getting into UVO? It won鈥檛 recognise my password and won鈥檛 let me reset it 馃檮 I tried re-registering and it wont recognise my VIN 馃槨
 

Super Moderator
Joined
2,445 Posts
Can I ask where you are based?
As not heard of this app in teh UK.

I have googled it and does not appear to have good reviews.
 

Registered
Joined
119 Posts
Never had any problems with Uvo since I installed it. (in the UK - it is a well-known app)
My only beef is that units are in kph not mph and I can't changeit
 

Registered
Joined
1 Posts
Is anybody having problems getting into UVO? It won鈥檛 recognise my password and won鈥檛 let me reset it 馃檮 I tried re-registering and it wont recognise my VIN 馃槨
Did you get a solution to this problem? I have the same issue.
 

Super Moderator
Joined
2,445 Posts
Try this thread.
 

Registered
Joined
614 Posts
I have had the app on my phone for about 4 months but I only got the car last week. I had already created the A/c just entered the VIN and away we went. Now, because of this lock down I ain't done any driving BUT regarding the KPH/MPH, at the top of the status page you have DTE and a refresh button. DTE is aways in KPH but if you refresh it does MPH. I really, really hate to ask this BUT:- have you changed your units on the settings page? I can hear the shouts already.馃殥馃挬
 

Registered
Joined
119 Posts
Although my settings were always set to miles I have just looked at the app and it has now been updated and shows my trips in MPH. Much better.
 
1 - 8 of 8 Posts
Top