Kia Owners Club Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi there is anyone else getting blank white screen when logging into the updated UVO app? I am on iphone 11 software version 14.8

I have turned my phone off and on. Deleted the app and reinstalled it. Each time I try to log in to control the charge start time of my XCeed Phev all I am met with is a blank screen so can’t charge at the times I want to.

Any ideas or top tips very welcome thank you!
 

·
Registered
Joined
·
1,177 Posts
I’ve installed Kia Connect and reset password, closed app, opened again and I still get a blank screen on login - very strange!
You shouldn’t have needed to reset your password, but that shouldn’t be the problem. Try messaging @KCS is the only other thing I can suggest.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
1,177 Posts
Hi there is anyone else getting blank white screen when logging into the updated UVO app? I am on iphone 11 software version 14.8

I have turned my phone off and on. Deleted the app and reinstalled it. Each time I try to log in to control the charge start time of my XCeed Phev all I am met with is a blank screen so can’t charge at the times I want to.

Any ideas or top tips very welcome thank you!
Has it EVER worked? Setting it up with the car is a bit less straightforward than it might be



Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
Has it EVER worked? Setting it up with the car is a bit less straightforward than it might be



Sent from my iPad using Tapatalk
Hi all thanks for the recommendations.

- yes I used to use the Uvo app and it worked fine (havent changed phone or car!)

- yes I deleted old Uvo app, then downloaded Kia Connect, turned off the phone, waited 5 mins to power up again… still no joy, blank white screen

no worries I will book into Kia service to diagnose

thanks for your efforts though!
 

·
Registered
MY21 Stonic GT-Line S ISG MHEV iMT - sw220211 - map14.47.48.631.401.5
Joined
·
581 Posts
Why don't you just submit an issue using the Contact Us | Kia Connect web-form?
They are better placed to help you at this stage since they can verify that there is no issue with the data they store for your account that might cause an issue.

Select Kia Connect General Support at the top, and then Kia Connect App Services, this will allow to specify the type of phone and the VIN of the vehicle too.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top