Kia Owners Club Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey all,

Many of you are probably suffering with that issue where the Niro loses the cars position as soon as night mode becomes active on the SatNav.
Anyway, I've been chasing KIA about this for some time and I finally have a response from KIA who have confirmed the issue is real and they are looking into it.

Here's there response on Twitter:
Font Darkness Terrestrial plant Brand History


When I get more information, I'll post it here.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
I think what OP is referring to is when sensor picks up it is dark. Not the actual "Dark Mode" you can set on the display.
Yes that's correct. Turning off night mode itself does not fix the issue. As soon as the sensor detects it's dark, it begins to mess up.
Other users have tested this by covering the sensor in the middle of the day and finding the navigation become unreliable within a few minutes.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
It's outrageous that Kia can get away with this. A car with inbuilt satnav that doesn't work after dark is a broken car and you should be able to take it back to the dealer for a refund. It works fine on mine (I haven't updated the software since November) so we all know it can work. 'Complex elector magnetic issue'! Rubbish! Duff software developers and a lack in interest in the customer, more like.
I agree. It shouldn't be acceptable... But funnily enough there's a lot of people suffering the same issue, so I can only assume it's a particular batch that was manufactured with a fault... Which leads me to think it's a hardware issue. But let's see
 
1 - 3 of 3 Posts
Top