Kia Owners Club Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I have a 2007 2.9 CRDi Sedona which has done 25k miles and isrunning very well with the exception of this annoying problem.
If you accelerate hard there is a rev band where there is a rattle/vibration which clears as you increase through therevs. Can sometimes also appear as you came back down the rev band. It also appears when the vehicle is labouring (high gear low speed).

At standing you can take revs up to 4000 + and no noise. ie. I can only make this happen when vehicle is actually moving.

Performance wise there are no issues whatsoever and it starts without problem. Only other info is that the day before I noticed this I stalled it at low speed whilst turning a corner in the snow. It's been there nowfor 6 weeks and both my local garage and a Kia mechanic were somewhat puzzled on a short testdrive and ofcourse identifying it could be time consuming it it won't do it on the ramps.

No visible signs of and failed mounting brackets or lose heat shields etc. Noise appears to be coming from passenger side of the engine bay.

Did initially panic that it might be a dual mass flywheel problem but if so I understand it would manifest itself whilst the vehicle was running even ifstationary ?

If it got worse it would be easier to identify but it doesn't seem to change or affect the vehicles performance.

Stuggling to think what it could be and would very much welcome any suggestions from this experienced group of owners.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #2
My problem still continues and unfortunately no suggestions as yet. Someone mentioned it might be clutch/gearbox related ..... does the Sedona have any history of manual gearbox failures or clutch problems which could manifest themselves in the problem I describe ?


If gearbox I'm very surprised it's not noisy all the time and even more surprised that it doesn't seem to be getting any worse ?



Help



Thanks

Ian
 

·
Registered
Joined
·
189 Posts
Hello Ian, have you ruled out road wheel imbalance?. I had an annoying vibration on an old Citroen diesel when under load at a specific rev band. Turned out one of the alloy wheels was notbalanced correctly.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #4
This noise is not a rumble or typical wheel/road noise related one, it has a definite metallic sort of noise with a harshness to it. As mentioned it almost sounds like an induction roar but struggling with that idea as it doesn't happen when you rev the engine at standstill. It clearly is related to load as it appears under harsh acceleration or when increasing speed at low revs (engine labouring).
No noise when pulling away from standstill and quiet as a mouse at 80-90 on the motorway which again I'm surprised at if it is the gearbox. Also, no excessive vibrations which I thought you would experience with gearbox problems.



Might have to bite the bullet and put it into KIA garage for them to investigate.



Also when engine plugged into a diagnostic tester it comes up "No Faults" so engine itself appears to be fine.



Appreciate your feedback and thanks .... all ideas are very welcome.
 

·
Registered
Joined
·
30 Posts
hi that sounds like you have a lump in the tyre wall or damaged wheel rim on the inside this would cause the vibration on the wheel in my case it was the lump on the tyre wall
 

·
Registered
Joined
·
4 Posts
Hi my sedona suddenly started with this vibration today its hard to describe but broadly similar to the descriptions above it just suddenly started but isnt getting worse but tonight i have noticed oil on the floor the sump pan is wet and there must be half dozen drips of oil on th e floor (ugh!) the vibration is sort of like your running on 3 cylinders but not loosing any power when you get to a certain road speed and revs at about 2.5k there is a horrible mettalic rattling sound can anyone shed any light at all on it for me
 

·
Registered
Joined
·
21 Posts
Discussion Starter #9
Hi,
Mine has just been into Kia Viking in Southampton for diagnosis and looks like it's the front subframe rear mounts which have perished - about £11 each and 2 hours labour to fit. Car is booked in for 25th March so can report back on how I get on.
Sedonas apparently not know to have gearbox problems so whilst still a possibility they think it very unlikely.
Also noted that I had loose lower gearbox mounts which were tightened and airbox hadn't been refitted correctly by my local garage (not Kia) at last service.
There is also a section of flexible exhaust at the front which was OK on mine but might be worthy checking on yours.
Hope this helps and best of luck.
Ian
 

·
Registered
Joined
·
22 Posts
front subframe mount and lower suspension arm bushes need to be checked first as these are very prone to failing although they normally give a knock noise when turning or stopping.when you get the vibration can you feel it more pronounced through the clutch pedal?? as i have had this fault a few times as the dual mass flywheel is put under extra load.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #11
Can't say I do and no vibration on tickover or when vehicle revved when stationary. Guess I need to see what happens when they change out the sub frame mounts but as mentioned they seem fairly confident that this is the problem.
 

·
Registered
Joined
·
4 Posts
Hi there

many thanks for the information mine is booked in to a local garage tomorrow. Mine seemed to suddenly start to vibrate only does it at about 2k rpm noticeable but a very minor vibration until you get over 50mph when stationary if you rev it to 2k vibrates then as well mine is an auto diesel i have looked in to it and there are now known problems with either type of gear box but it seems that all the mounting rubbers are prone to wear as the car gets older i willpost again tomorrowyou as soon as mine has been looked at again many thanks for the reply.
Its a big thirsty bus but i love driving it especially on long journeys

Best regards
Trev Wildman

P.S. how old is yours and what millage? Mine is a 2000 and done 107k miles. Might be an age and millage thing (i know how it feels lol)
 

·
Registered
Joined
·
21 Posts
Discussion Starter #13
Hi Trev,

Mine is a youngster, 2007 with only 26k miles on the clock so you can understand that I would be disappointed if it was truly a gearbox problem ! Let me know how you get on with your repairs

Cheers
Ian
 

·
Registered
Joined
·
16 Posts
I have a 2007 sedona and been experiencing vibrations at the off side front wheel. Checked al ball joints but noticed the front sub frame rear OS bush has fallen apart.I expect this is not under the 7 year warranty. Can I buy the bush and fit this myself - very competent engineer.
Please advise .
 

·
Registered
Joined
·
4 Posts
Vibration Have so far not found a cure to the vibration problem although it is not getting any worse the car was checked over again nothing found, as you say at standstill rev the engine and there is nothing its only when your movingthat it happens and it is worse at about 2k revs having said all that The BLO***Y head gasket blew on saturday
so what is that all going to cost and pointers from anyone would be great (never had these problems with me old vaux cavalier)
 
1 - 15 of 15 Posts
Top