Kia Owners Club Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
hi, have got a 06 sportage, had it about 4 weeks, (good tow car i might add,) do they suffer from turbo lag between 1st and 2nd gear? because when i change up there is a second of hesitatsion? is this normal ? and is this turbo lag or not? because im not that cluded up on this cheers? And also there is a noise when i depress clutch pedal, dealer say cannot find anything wrong with clutch? As i tow a caravan this worrys me thanks
 

·
Registered
Joined
·
197 Posts
I've not noticed any lag when changing-up...but I have the 138 BHP CRDi - is yours one of the earlier models which has less power and a different turbo?

What is very noticeable is that 1st is very low geared for off road work and around town can be a bit of a nuissance - good for towing starts up hill though.

Hard to comment on a noise you can't hear.
 

·
Registered
Joined
·
97 Posts
Hi Scott100,


I have had the same symptoms on my 06 plate 138bhp six speed ???? have a read of my post Clutch or gearbox turbo?????

Had mine to the dealers today, they downloaded the ecu and updated my ecu ???? I reacon this is what you need too mate, got to give it 100 or so miles for it to relearn but i have noticed a change already. and only drove 30 or so miles with the updated ecu softwear ???? will let you know how it goes and same with you. ?????



hope this helps mate



Lance
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
lance how you going on with updated softwere? My sportage seems to hersertate in second gear when you put foot down? apart from that its fine?
 

·
Registered
Joined
·
97 Posts
hi scott, it does se quicker off the mark and i have only once had the automatic feeling in 3rd gear ?? other than that its loads better, wife towed for the first time with the sportage and she had it in 6th gear and creeping upto 70 so she had to keep a close eye out onit lol, think mileage is about 38mpg but not 100% sure. seems better after the ecu download and software update though :)
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
JUST BEEN TO DEALER TODAY FOR SOFTWARE UPDATE? WILL SEE IF THIS MAKES A DIFFERENCE? HOWS YOUR GOING ON LANCE? HAS IT SORTED IT ?
 

·
Registered
Joined
·
97 Posts
Hi Scott,


Going back in to the Dealers, still pulls off ok etc as it has improved it no end BUT i havent been using the car for over two weeks as had a double hernia op, so the wife has used the sportage and it seem's the lag in the gearbox or clutch or whatever it is has started again :-(

whilst in 3rd, 4th and 5th and going at speed its like a
Automatic waiting to kick up into a higher gear ???? anyone got any ideas ???



thanks



Lance
 

·
Registered
Joined
·
11 Posts
I have a 2005 113BHP XS 2.0 CRDI Auto and had a similar problem - lag was terrible and tractor-like performance when accelerating.
Just fitted a Pro-Bitz engine management chip and the difference is phenomenal. Well worth £90 and fitted in about 30 minutes (and I'm hopeless with cars and engines). Have to wait to see what it does to the fuel economy but I'm optimistic. Really pleased with result as I was very sceptical and spent weeks reading mixed reviews before taking the plunge.

 

·
Registered
Joined
·
97 Posts
funny that Jim, I was thinking about getting one of them too ?? I put a poet up ages ago and there was mixed feelings. think im going to invest in one when i build my paypal account up ;-)
please keep intouch, and let us know if you get any better fuel economy ?????

me and Scott both tow a caravan and the extra torque would be great.



cheers
 
1 - 11 of 11 Posts
Top