Kia Owners Club Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
390 Posts
Discussion Starter · #1 ·
My temp gauge is not moving but heater and water etc...ok. I think the 'sender' has gone. Is the senderfitted to where the 'small radiator cap' is. If so do I just undo and fit new one. Any tips.
Thanks Steve Blackpool
 

·
Registered
Joined
·
702 Posts
stevegx said:
My temp gauge is not moving but heater and water etc...ok. I think the 'sender' has gone. Is the senderfitted to where the 'small radiator cap' is. If so do I just undo and fit new one. Any tips.
Thanks Steve Blackpool
Steve

It just screws in and is where you said it is, just under it. Has the wire come off the sender ? I know when I'vebeen doing stuff around it I have knocked it off
 

·
Registered
Joined
·
390 Posts
Discussion Starter · #3 ·
Hi Bruno.

Will double check but looks as tho wire is fixed to conector.
Will any year Kia sedona sender do or does have to be for 2001 'Y' tdi s 2.902?

Thanks Steve G
 

·
Registered
Joined
·
702 Posts
stevegx said:
Hi Bruno.

Will double check but looks as tho wire is fixed to conector.
Will any year Kia sedona sender do or does have to be for 2001 'Y' tdi s 2.902?

Thanks Steve G
Steve

I'm almost sure the connector and the cable are one and just pull off. I can have a look Monday to chack if you want.
 

·
Registered
Joined
·
390 Posts
Discussion Starter · #7 ·
anjy834u said:
get ur sedona to a dealer. this sounds tricky to me.


Its ok on any car this is a simple cheap parts job.
Steve G

This is my first try at using quotes box
 

·
Registered
Joined
·
390 Posts
Discussion Starter · #8 ·
bruno1926 said:
stevegx said:
Hi Bruno.

Will double check but looks as tho wire is fixed to conector.
Will any year Kia sedona sender do or does have to be for 2001 'Y' tdi s 2.902?

Thanks Steve G
Steve

I'm almost sure the connector and the cable are one and just pull off. I can have a look Monday to chack if you want.
HI I mean that it is possible the wire has cracked or come off the connector itself not the sender.
Steve G
 

·
Registered
Joined
·
702 Posts
stevegx said:
bruno1926 said:
stevegx said:
Hi Bruno.

Will double check but looks as tho wire is fixed to conector.
Will any year Kia sedona sender do or does have to be for 2001 'Y' tdi s 2.902?

Thanks Steve G
Steve

I'm almost sure the connector and the cable are one and just pull off. I can have a look Monday to chack if you want.
HI I mean that it is possible the wire has cracked or come off the connector itself not the sender.
Steve G
Hi Steve

Just checked on mine (W reg) and it just pulls off the sender its a blade type electrical connectot and the sendorm just screws out. As you look at the filler neck on the drivers side of the car ,look blow and towards the firewall and its there ,its not the multi block connector just above towards the front of the car. Hope this makes sense
 

·
Registered
Joined
·
390 Posts
Discussion Starter · #10 ·
bruno1926 said:
stevegx said:
bruno1926 said:
stevegx said:
Hi Bruno.

Will double check but looks as tho wire is fixed to conector.
Will any year Kia sedona sender do or does have to be for 2001 'Y' tdi s 2.902?

Thanks Steve G
Steve

I'm almost sure the connector and the cable are one and just pull off. I can have a look Monday to chack if you want.
HI I mean that it is possible the wire has cracked or come off the connector itself not the sender.
Steve G
Hi Steve

Just checked on mine (W reg) and it just pulls off the sender its a blade type electrical connectot and the sendorm just screws out. As you look at the filler neck on the drivers side of the car ,look blow and towards the firewall and its there ,its not the multi block connector just above towards the front of the car. Hope this makes sense
Thanks Bruno Will look atit with your info thanks. Steve G
 

·
Registered
Joined
·
390 Posts
Discussion Starter · #11 ·
DOH...I have fixed my sensor I was looking at the wrong thing. Similar sensor to the one I waschecking, behind and below about 3 inches away. All it was....it had comeoff !!!!! :O))
Steve G
 

·
Registered
Joined
·
702 Posts
stevegx said:
DOH...I have fixed my sensor I was looking at the wrong thing. Similar sensor to the one I waschecking, behind and below about 3 inches away. All it was....it had comeoff !!!!! :O))

its easy to do with the big multiplug just above it, its easy to catch and pull off if you are working in that area
Steve G
 
1 - 12 of 12 Posts
Top