Kia Owners Club Forum banner

1 - 7 of 7 Posts

·
Registered
Picanto 1.0T GDi GT-Line
Joined
·
1,055 Posts
Discussion Starter · #1 ·
Sorry if this is obvious but I've just bought a 2018 1.0t GT line and I'm having trouble starting with the key on occasions. It was first registered on the 31st December 2018 (2 yrs old) and it's covered 6,900 miles. It's key start option (no smart key which I'm pleased about) however sometimes it won't start, like the immobiliser has kicked in. I put the key in, turn to accessory and 'checking system' comes up, but nothing when I turn to 'start'. This happens whether my foot is on the clutch and/or brake or not, (and I'm not pressing the throttle). Then after the 3rd or 4th attempt it starts happily. Other times it just start first time. It has 2 keys and it's the same with both. I would ask the dealer I bought it from but after asking him today why there was no DRL, and being patiently told that the DRL's only come on when the car is in gear, I thought I would ask on here first. Something I need to know or faulty?
By the way I love that engine!
 

·
Registered
Joined
·
211 Posts
Are you sure you’ve got the clutch fullly depressed, ie right down to the floor, each time? It’s easy to just bring it up a fraction and the engine won’t start. I’m assuming there is a sensor that is set lower than the normal ‘bite’ point of the pedal (?)
 

·
Registered
Joined
·
1,060 Posts
Been reading about these switches and looking at vids.. this one is not a Kia but might be a way to confirm that yours may have a duff switch..

 

·
Registered
Joined
·
531 Posts
DRLs do not work with handbrake on. The in gear thing is an uninformed dealer!(which seems to be a common UK thing)

The clutch is the only interlock on mine, sounds like a miss adjusted switch or dodgey ignition. Do you have your house keys on the keyring also?
 

·
Registered
Picanto 1.0T GDi GT-Line
Joined
·
1,055 Posts
Discussion Starter · #5 ·
DRLs do not work with handbrake on. The in gear thing is an uninformed dealer!(which seems to be a common UK thing)

The clutch is the only interlock on mine, sounds like a miss adjusted switch or dodgey ignition. Do you have your house keys on the keyring also?
Yes, one key has the house key (and Tiger beer bottle opener... because you never know) attached but it can happen when I just use the spare key on it's own. I've tried it a couple of times this morning with the clutch pedal firmly pressed to the floor and it seems to work as it should. Maybe I had not pressed the clutch down far enough previously? I'll see how it goes.... Many thanks.
 
  • Like
Reactions: GarethR

·
Registered
Picanto 1.0T GDi GT-Line
Joined
·
1,055 Posts
Discussion Starter · #7 ·
Maybe you have thick mat/ s bunched under it preventing full travel!
Since I've been squashing the pedal to the floor it seems to be fault free now. Fingers crossed it was just a jobs worth switch. Thanks all!
 
  • Like
Reactions: GarethR
1 - 7 of 7 Posts
Top