Kia Owners Club Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
161 Posts
Discussion Starter · #1 ·
after the snow had cleared noticed what appeared to be white staining comeing through on drivers/passengers foot well carpets.dealer had a look when car was in for fit for accesories and said proberbly salt off shoes from recent snow.though i was very carefull when entering car to give feet a clup to remove snow.
today vacumed car ,white tide like marking on both rug undersides and fitted carpets.it is white in colour.the drivers side foot well seams very spongey though dry.the front wells are double rugged,since i purchsed the car,because of the winter conditions and i did want to protect the carpets...so it seems im getting some sort of water penatration from else where.anyone else had any experiences?









soul crdi[09]2010
 

·
Registered
Joined
·
2,252 Posts
Zumbie have a look under carpets the sound deadening foam could have soaked up water. It also could be salt off shoes you can never be 100% sure of getting it all off your shoes.
 

·
Registered
Joined
·
1,605 Posts
this is a common complaint on the USA website. It appears to be some sort of powder they use when assembling the cars. The American owners are having their carpets replaced under warranty where its not removable.
 

·
Registered
Joined
·
32 Posts
I have white stains on mats - just assumed it was salt from shoes/boots during snow, finally drying off. Must have a look at carpets too.
 

·
Registered
Joined
·
1,605 Posts
if its on the mats it is probably salt. The white powder i am talking about usually shows where the cars carpet joins or is trimmed round fixings ie round the seat fixing points, or under the dashboard. It seems to be some sort of powdered lubricant (talcum powder type stuff from the USA owners description). That the factory use or over use slightly.
 

·
Registered
Joined
·
161 Posts
Discussion Starter · #7 ·
thanks tempest,had alook at the usa site last night.i have the marks on the door ridges as well.looked at the photos on the usa site and its exactley like mine...looks like trip to dealers.the guy on the usa site had the problem cured,cause was diccolated air con drainage hose.as i said on previous thread the wells are double rugged with the top one rubber underside.its defo comeing upward from floor.....will futher inspect on monday...and then trip to mr.maindealer Edited by: zumbie
 
1 - 9 of 9 Posts
Top