Kia Owners Club Forum banner

1 - 2 of 2 Posts

·
Read Only
Joined
·
2 Posts
Discussion Starter #1
Hi, I have just joined the forums as I have a specific problem which I really hope you can help with.

I have a 59-plate Kia Soul. A couple of weeks ago when I started it up one morning, the radio display was blank. You know how it normally shows clock and temperature, even when switched off? There was nothing. No display, and none of the buttons worked. Totally dead. (It had been perfectly fine the last time I'd driven the car, a few days prior).

Long story short I sourced a replacement second hand (after discovering my local Kia dealership wanted £1600 to fit a new one!). With the help of some car trim removal tools I got the old radio out, plugged in the new one and... yippee! It worked.... well, sort of.

Which brings me to here. The problem I now have is that the volume on the new radio is painfully low. Even turned up fully I can barely hear it with the engine running.

I've now been told that some Kia Soul radios have a built-in amplifier, and some don't. So the gist being that my old radio did, and the new one doesn't.

Trouble is - and hence why I'm desperately seeking help - is that I cannot find any information online as to which models / part nos of radio have a built-in amplifier and which don't.

So... please can anyone advise? First of all, is it correct that some Kia Soul radios have an amplifier built in and some don't? Is there an easy way I can tell if I have an external amplifier in my car?

There were no volume issues with my old radio, nothing to indicate it was about to give up the ghost.

Thanks in advance ?
 

·
Read Only
Joined
·
2 Posts
Discussion Starter #2
I forgot to mention... in case it is relevant... the only thing that was still working on the old radio was the buttons lighting up when the car headlights were on.
 
1 - 2 of 2 Posts
Top