Kia Owners Club Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My Sorrento 2.5 occasionally will not accelerate over about 10 mph on pulling away from start up.
Has anybody encountered this?

I have reported it to the Kia servicing garage since it was new they check and find nothing but still it keeps returning !
 

·
Registered
Joined
·
6 Posts
Now thenI was in a similar predicament with my magentis the garage ran all the test's and said they couldn't find the fault, they were just about to give me the car back under the
"we can't find the fault but it hasn't din it since"

school of thought(which took 8 working days i might add & i was given a Peugeot 207 by KIA assist as a courtesy car (goggle it and then compare to mine) but thats just sour grapes, anyway at 9:AM i get a call to pick the car up and at 4:30 pmi get another call to say it was the RGU filter whichrecycles the carbon that comes through the engine. Apparently theRGU filtercarries the carbon and if it isn't flushed periodically(This is where you see the boy racers tearing up and down the strip with black exhaust fumes trailing the car, if it isn't done which was in my case the RGU valve carbonizes, sticks thus stops. Mine happened under warranty so i hope has yours if that's what the problem is. anyway best of luck I've been without my car for coming up to 2 weeks now i hope yours is alot quicker to resolve.




P.S

Don't even get me started on the customer service...................
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I was given the impression the service manager thought that I had imagined the problem!
Thanks for the information I will ask them to check it although the car is out of warranty I have complained for over a year now so maybe they will make allowances.



Customer service!!!

Once , among other things, I received the car back with ablack imprint on the back seat where a mechanic had sat getting a lift home! Never mind the car not being cleaned it was considerably dirty than before the service!
 

·
Registered
Joined
·
4 Posts
Glad you mentioned the state of your car when being returned. Mine comes back worse nearly everytime I take it in! I have 2 dents in the tailgate and a nice oily handprint on the rear seat. Of course, it's my fault for not doing a complete body check before I leave the workshop.
 

·
Registered
Joined
·
6 Posts
My Sorrento was purchased earlier this year as an ex demonstrator with 3.5K miles and I have now cleared 12K miles.I have experienced this faultof flat accelaration,a couple of times getting out of junctions and also a client of mine offered to move my vehicle and he experienced the same fault and he is a class one police driver.I have found that an Italien tune up seems to have stop the problem,that is to race the vehicle through the manual gearchanges which seems to clear deposits from the engine.My driving can consist of a period of short local journeys and times of extended journeys.
This issue was reported to Kia when the vehicle was recently serviced but I had to book a new appointment with the warranty mechanic which I haven t bothered with.

With the current clean exhaust systems (ie particulate filters)a lot of diesel engines need to be revved to allow the systems to operate efficiently,if you do a lot of short journeys at modest revs the exhaust valves systems clog up.Still like the vehicle though.
 

·
Registered
Joined
·
31 Posts
Tone said:
Now thenI was in a similar predicament with my magentis the garage ran all the test's and said they couldn't find the fault, they were just about to give me the car back under the
"we can't find the fault but it hasn't din it since"

school of thought(which took 8 working days i might add & i was given a Peugeot 207 by KIA assist as a courtesy car (goggle it and then compare to mine) but thats just sour grapes, anyway at 9:AM i get a call to pick the car up and at 4:30 pmi get another call to say it was the RGU filter whichrecycles the carbon that comes through the engine. Apparently theRGU filtercarries the carbon and if it isn't flushed periodically(This is where you see the boy racers tearing up and down the strip with black exhaust fumes trailing the car, if it isn't done which was in my case the RGU valve carbonizes, sticks thus stops. Mine happened under warranty so i hope has yours if that's what the problem is. anyway best of luck I've been without my car for coming up to 2 weeks now i hope yours is alot quicker to resolve.




P.S

Don't even get me started on the customer service...................

Too small
 

·
Registered
Joined
·
31 Posts
I had a similar problem with mine i felt more like a misfire and i was advised to stop using supermarket Diesel so i filled up at a Main brand filling station and had no problems butafter i filled up at **sc*s and the problem returned
 

·
Registered
Joined
·
31 Posts
Patrick L said:
Customer service!!!

Once , among other things, I received the car back with ablack imprint on the back seat where a mechanic had sat getting a lift home! Never mind the car not being cleaned it was considerably dirty than before the service!

A largeish dealer near me had my first Magentis in for an airbag recall in 2003 when it was 3 months old and when i got the car back the dash was cracked & scuffed and had pry bar marks around the edges of the trimand it rattled too also a dent in the rear arch. after a lot of complaining they replaced the damaged dash but acted like i was being unreasanoble by complaining in the first place
 
1 - 8 of 8 Posts
Top