Kia Owners Club Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have 2006 Sorento , its the base version with manual selection of 4WD/Low ratio.


I wonder if any member can help. I am getting vibration felt throuh accelarator pedal, gear lever and seats/floor. Steering wheel not vibrating. Tyres are original.Car has done 26,000mls



It seems speed related at ~28-30mph , ~36-38mph and ~56-60mph.

I dont think it is discs . I had this problem near new and discs replaced (symptoms werent the same).I am not getting vibration under braking. Seems more when under accelaration/load.

I have had front wheels balanced - no change

I have had rear wheels balanced and put on front - no change.



I havent entirely ruled out it being related to engine RPM - around 1500RPM.



Any ideas ... as I dont know where to go next.



thanks in advance
 

·
Registered
Joined
·
662 Posts
check front propshaft slider and yoke see previous posts on this subject also has the transfer box oil been changed to the tod oil as now specified
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for your reply
Sorry but didnt understand 'to the tod oil as now specified ' what is tod oil please ?

Hope I am not being too thick
 

·
Registered
Joined
·
93 Posts
Hi Mike



Welcome to the forum



tod = torque on demand

Kia's are very fussy about correct oils and filters.




Remember there is no such thing as a stupid question - but plenty of folk make stupid assumptions............
Edited by: UncleMart
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I thought I should post the fix.


Took it to the Kia garage as quite a lot of possibilities.


They advised to change the transfer box oil - Torque on Demand oil.


We went with this and they said oil looked in poor state.


Vibration has gone.


Thanks for the many posts .


mikebav
 

·
Registered
Joined
·
93 Posts
Nice one Mike - thanks for sharing that




I'm glad you got it sorted and nothing serious
 
1 - 7 of 7 Posts
Top