Kia Owners Club Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
So, very unhappy right now. Went for like 700km trip yesterday and my Sorento didn't behave like expected :-(

Driving in AUTO mode witch smart cruise control set to 130km/h I suddenly seen the speed is dropping down to 110km/h without apparent reason. No reaction at all when I pressed gas pedal. I spotted the car is locked in EV mode, battery almost drained (was on 2% only - never seen anything below 10% till this moment). I tried to manually change the mode to HEV, no reaction on pressing the button, just warning message about overheated electric system. After few more attempts I switched it to HEV. There was many unpleasant shakes with engine and car and battery started to charge only after I changed to sport mode. Had a stop on gas station to try the IT way - switch it off and on again. Helped from point of battery recharging behavior, but the ride wasn't smooth anymore. When I came from highway to city, it felt like transmission issues, awful behavior when slowing down (first like i'm not breaking at all then sudden kicks from breaks and engine) and issues with acceleration too (like if there is neutral put in during shifting - revs go suddenly too high and then full power kick's with whole car). I believed that my transmission is dead. But today after charging battery and driving in EV mode only all was smooth.... just after third start the message in subject was displayed and since then engine light is on on the dashboard. Waiting for appointment in my dealership right now.... Did somebody of you experienced such behavior? ....5000km driven only
 

·
Registered
2022 Kia Ceed SW PHEV
Joined
·
58 Posts
Sorry to read about this issue you are having LBH. Haven't come across this previously. From what you have posted, the issue appears to be with the ICE and the car not trusting itself to transition from EV to ICE due to the issue. The engine warning light would seem to support this.
Hope you get an early appointment with the dealer. While this will be fixed under warranty, it is disappointing in a new car.
 

·
Registered
Joined
·
83 Posts
So, very unhappy right now. Went for like 700km trip yesterday and my Sorento didn't behave like expected :-(

Driving in AUTO mode witch smart cruise control set to 130km/h I suddenly seen the speed is dropping down to 110km/h without apparent reason. No reaction at all when I pressed gas pedal. I spotted the car is locked in EV mode, battery almost drained (was on 2% only - never seen anything below 10% till this moment). I tried to manually change the mode to HEV, no reaction on pressing the button, just warning message about overheated electric system. After few more attempts I switched it to HEV. There was many unpleasant shakes with engine and car and battery started to charge only after I changed to sport mode. Had a stop on gas station to try the IT way - switch it off and on again. Helped from point of battery recharging behavior, but the ride wasn't smooth anymore. When I came from highway to city, it felt like transmission issues, awful behavior when slowing down (first like i'm not breaking at all then sudden kicks from breaks and engine) and issues with acceleration too (like if there is neutral put in during shifting - revs go suddenly too high and then full power kick's with whole car). I believed that my transmission is dead. But today after charging battery and driving in EV mode only all was smooth.... just after third start the message in subject was displayed and since then engine light is on on the dashboard. Waiting for appointment in my dealership right now.... Did somebody of you experienced such behavior? ....5000km driven only
I agree with Greyhound. I have owned the Sorento PHEV for 12 months and never seen this issue. Seems to be a component failure of some sort.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #5 ·
Ok, so... KIA inspected my car. They told me there were some communication errors that probably caused weird behavior of car management unit, resulting into symptoms I described above. They reconnected connectors (unplugged and plugged back - not sure on what units/devices) to make sure they are fit ok, performed KDS test and as all went ok, erased the errors from car memory. Car behaved ok on test ride, so the result is that I should drive as usual and if the issue repeats, I will come back to KIA and they will - this made me smile - replace something :) So hopefully the issue never comes back :)
 

·
Registered
2022 Kia Ceed SW PHEV
Joined
·
58 Posts
Thanks for the update LBH. Great that they didn't think it was a big issue and appear to have resolved it.
I was thinking about your post afterwards and that it might have been a low charge on the 12v battery. That can cause issues with transitioning in between EV and ICE in PHEVs of different makes and models.
Hopefully what they have done resolves the issue. Funnily, the issues I have seen/read on PHEVs appear on the face of it to be big and complicated issues but are usually resolved by simple or straightforward fixes.
 
1 - 6 of 6 Posts
Top