Kia Owners Club Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi all new to this kia forum. I have a 54 sorento 2.5 xs with only 45000 miles on the clock. I have been reading the posts as to the common problem of the engine cutting out under acceleration. Which mine has started doing. I have had the fuel sender unit out and cleaned thefilter in the unit but is was pretty much as clean as it sould be. This may sound thick to some but is the cam sensor and crank sensor the same and is it worth exchanging them. Any help would be greatly received.Thanks Andy.
 

·
Registered
Joined
·
18 Posts
Have you changed the fuel filter?if not change it for a genuine one.Crank/cam sensor tells the ECU where TDC is( Top Dead Centre ) if this fails usually engine will not run at all.Also you would have an engine management light on in the dashboard.If you have a clean fuel system and filters and problem persists you may be sucking air in through a worn seal.
 

·
Registered
Joined
·
13 Posts
Hi Andy,
Can't comment much on the mechanics I've had the same trouble broke down twice, the cars been in the garage for two day's now the garage supervisor phoned to give me an update. They are pretty much stumped they are going to a KIA dealers to see if the can offer a solution.



By all accounts they have cleaned and checked fuel lines , injectors and tested the deisel fuel for contaminates as I had a funny burning smell from the exhaust since I bought the car which was only a week ago.



I will keep you posted when the finally sort this out



Ta



Andy
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Hi all. Thanks for the replys. I assume the fuel filter has been changed as i have it serviced every year at a garage(none kia dealership) and this was only done 3 months ago but for a guess i dont think it will be a geniune kia filter so i may start with that i see if that makes a difference. Andy
 

·
Registered
Joined
·
15 Posts
Had the same issue with my old 05 Sorento, kept cutting out and only when I primed the fuel filter would it start again (there is a spring loaded pump button on the filter housing). I replaced with a OEM filter and the problem went away. Then I upgraded to a new shape sorento and have lived to regret getting rid of the old shape. Worst decision of my life, seriously. Try the filter and should fix you up.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Hi all. I have had the fuel filter changed to a oem filter and my car has'nt cut out for 3 days now so hopfully this has cured the problem.Thanks to all for the replys.
 
1 - 7 of 7 Posts
Top