Kia Owners Club Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Good afternoon all,

I recently purchased a 2.2 diesel sorento manual KX2, I bought the car knowing the AWD was not functioning but my knowledge is limited and was hoping somebody may be able to shed some light for me.

When the car is on axle stands all round, the front wheels spin in all gears but no drive to the rear. When you turn the prop manually the rear wheels spin. I put the car in 1st with the engine off and the prop still spins the rear wheels, to me this doesn't seem right so I'm thinking the problem lies at the front somewhere?

Was thinking perhaps the teeth are worn where everything links to the gearbox?

My main Question is.. is where it attaches to the gearbox toothed in the box itself or is there a toothed sleeve that fits inside and houses the teeth of the coupler?

I hope this makes sense? My mechanical knowledge is limited but I'm getting there

Many thanks

Tom
 

·
Registered
Joined
·
5,229 Posts
This sounds perfectly normal to me, The car is normally 2WD fronts only and will engage RWD when it detects the fronts slipping, or it is manually locked into 4WD. If you were to start it on the stands and put it in gear then it will propbably drive the rears.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
This sounds perfectly normal to me, The car is normally 2WD fronts only and will engage RWD when it detects the fronts slipping, or it is manually locked into 4WD. If you were to start it on the stands and put it in gear then it will propbably drive the rears.
Hi, I probably didn't word my post very well but while it was on the stands I ran it up in 1st-4th gear and just the front wheels were spinning, no drive to the rear at all
 

·
Registered
Joined
·
4,882 Posts
When up on stands and fronts turning is the prop shaft turning. If not transfer box isn't driving suggesting gears have gone. Suggest drain the oil from it and look for metal filings.
 
  • Like
Reactions: Indalo

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
When up on stands and fronts turning is the prop shaft turning. If not transfer box isn't driving suggesting gears have gone. Suggest drain the oil from it and look for metal filings.
Thanks for your response,

When in the air and driving the front wheels, the prop doesn't move at all.

You can turn it by hand and the rear wheels turn but no drive from the engine.

Many thanks
Tom
 

·
Registered
Joined
·
4,882 Posts

·
Registered
Joined
·
1 Posts
Good afternoon all,

I recently purchased a 2.2 diesel sorento manual KX2, I bought the car knowing the AWD was not functioning but my knowledge is limited and was hoping somebody may be able to shed some light for me.

When the car is on axle stands all round, the front wheels spin in all gears but no drive to the rear. When you turn the prop manually the rear wheels spin. I put the car in 1st with the engine off and the prop still spins the rear wheels, to me this doesn't seem right so I'm thinking the problem lies at the front somewhere?

Was thinking perhaps the teeth are worn where everything links to the gearbox?

My main Question is.. is where it attaches to the gearbox toothed in the box itself or is there a toothed sleeve that fits inside and houses the teeth of the coupler?

I hope this makes sense? My mechanical knowledge is limited but I'm getting there

Many thanks

Tom
[/QUO,TE],
hi tom, my 2013 kx2 had no drive to the rear wheels only front wheels spinning in wet ,a machanic found the awd coupling on rear axle was broken where the input shaft is welded to the clutch carrier ,he welded it and turned it down on a lathe ,now awd works as it should ,cost was around 200 hundred pounds.
 
1 - 8 of 8 Posts
Top