Kia Owners Club Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all, new to the page but I’ve got a 2013 Kia Sportage CDRI 2 and every so often it’s been sluggish acceleration and won’t go above 3000 revs, any one with any idea on here?
Been reading it could be the fuel filter or an ecu misreading a signal, just hoping someone has had it before on my vehicle type so I have an idea before either doing it myself or going to the garage.
 

·
Registered
Joined
·
33 Posts
Could be an air leak Split hose.
ODB readers are really cheap and may be able to help although may not be able to read all codes.
 

·
Registered
Joined
·
1 Posts
My 2014 sportage 3 just started this also. I asked the local Kia dealership, they suggested changing the fuel filter. By the time I got home I had a fault code P2563, turbo charger boost control position sensor. Plan on changing the fuel filter first, but I’m struggling to find anything on youtube of google on changing the fuel filter on my 2014 model to reference.
 

·
Registered
Joined
·
1 Posts
My 2014 sportage has been doing this too. It happens when it's very cold. I had read that the diesel thickens because of the cold and this is the cause. Today the engine management light come on when I accelerated a little heavier. This same issue happened 2 years ago (during a cold spell -10C). I took it into the garage where it was fixed (not sure what they did). What's annoying me is that this seems to me like a design fault.
 
1 - 6 of 6 Posts
Top