Kia Owners Club Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I love my 2002 Sedona but it's doing me an my mechanic's head in at this moment
.


The engine starts ok and might drive ok for a while. For some reson the engine management light comes on and either one or two things happen: Either the engine cuts out altogether and only comes back to life when you take your foot off the excelerator perdal. After 2-3 seconds with no gas applied the light goes out and the power comes back to normal, either that or when the management light comes on the engine loses most of its power but again comes back after 2-3 seconds off the accelerator pedal.<?: prefix = o ns = "urn:schemas-microsoft-com:eek:ffice:eek:ffice" />



Just to make matter worse to diagnose, the car might start ok but then stop immediately, not willing to start for a few minuits or it will start with easystart!! Also it sometimes cuts out when you brake at a junction, especially if it's a downhill gradiaent.

Some time ago I did have something simular but it dissaperared after a couple of months. On this occasion the engine manangment light would come on during moderate acceleration, say, going up hill on the motorway. If you didn't back off the accelerator, untill the light went out, the engine would cut out completely and power would only come back when the accelerator pedal was released for 2-3 seconds, which extinguished the engine management light and the power would return. I assume my current problem is linked to this previous problem.
I have replaced the fuel filter, air mass meter, checked the water levels and fiddled with all wires arround the engine. This does not help. ANY SUGGESTIONS PLEASE??
 

·
Registered
Joined
·
42 Posts
Big suggestion....part ex it because its fuel pump is slowly dying and it will cost you aFORTUNE to fix.


My 51 plate has been in my local garage since Christmas ( they tend to take time over these things...but we get a spare car and the bill is always cheap ).



Mine started displaying a fuel light under load 20 months ago. It initially came on ONLY when towing my caravan under hard acceleration.



At the beginning of last year I spent £700+ quid on a major service which included full timing belt change with pulleys/water pump ( and fit a used aircon pump to get the a/c working ). This was all in readiness for a big Euro caravan tour.

In August ,I towed my caravan to France and the ECUlight started to come on much more frequently. We had to limp home from the Vendee and there were times climbing up steep hills we were at 30mph.



When I got back home I went about getting it diagnosed by a diesel expert. Essentially, the light comes on because there is not enough fuel pressure to service the injectors This is caused by a pump 'in decline' or a fuel injector which is not holding pressure and leaking off back to the common rail system.



My tale of woe was that ALL my injectors were diagnosed as overheated/wrecked so I had to replace the lot at a total cost of ~£1100. While my breathwas taken back by the cost, the positive news was that there were no metal particles found, which meant the fuel pump must be okay......

..so I get the car back and its initially okay for a few weeks ( no ECU light ). But after a few more weeks I notice atapping/chuffing noise and feel the engine is noisierthan I'm used to. I take it to the diesel specialist and he reckoned the injectors weren't coded right and one or two were loose.

So I went back to my mechanic to tell him its a poorly car and he takes it back off me for further checks.



The checks uncovered that two of my new injectors got busted due to metal particles. The new injectors holding pressure caused more load on a pump which was too tired and it started to break up. I have had to pay the diesel specialist £715 for a new pump andnew sets of internals for two of the injectors. Whenthe car went back over xmas, that was also because the gear linkage cables snapped. I haven't yet worked out the bill with the gargage for fixing the gear cables and fitting the injectors/pump.



Recap :

1)Car worth ~£2000 tops

2)Spent £700 + £1100 +£715 +~£500(guesstimate forfinal bill ) inside 12months



Conclusion : Should have sold it for scrap last year , now stuck with it cos can't afford another car :-(




Edited by: ebod
 

·
Registered
Joined
·
249 Posts
It can also come on because of a faulty brake light switch. I had exactly what you describe & I traced it to an incorrectly set up switch. Once set right the prob. disappeared & that was 9 mths ago.
 

·
Registered
Joined
·
42 Posts
Not based on this comment its not :-
"On this occasion the engine manangment light would come on during moderate acceleration, say, going up hill on the motorway. If you didn't back off the accelerator, untill the light went out, the engine would cut out completely and power would only come back when the accelerator pedal was released for 2-3 seconds, which extinguished the engine management light and the power would return."



been there , done that and got a VERY EXPENSIVE T-SHIRT.

Mikey from Sheffield, hope you're reading this...you have been warned.
 

·
Registered
Joined
·
249 Posts
Yep, that's exactly what mine did ,plus it would occasionally do it on rough roads. Not saying that it's not what you had but that was exactly the symptoms of mine. Once I removed switch I found the plastic part where the cables plug in had become loose due to incorrect fitting,causing too much pressure on the switch when pedal released. I just reclamped the lugs, set it correctly & it's been fine since.
 

·
Registered
Joined
·
2 Posts
m y sedona management comes on on and goes off if i accelerate on inclines no loss of power starts and drives spot on all belts filters been changed im stumped any ideas be grateful or car got to go
 
1 - 6 of 6 Posts
Top