Kia Owners Club Forum banner
1 - 7 of 7 Posts

·
Registered
2021 XCeed 3 1.6 CRDI Phantom Black
Joined
·
22 Posts
Discussion Starter · #1 ·
I normally send routes to my car using the UVO app but the last few days I either get 'no response from vehicle' or it sends but the screen says it can't be set and I have to press the Navi button on the car display to get it to do anything. Anyone else having issues?

Thanks.
 

·
Registered
2021 XCeed 3 1.6 CRDI Phantom Black
Joined
·
22 Posts
Discussion Starter · #2 ·
It looks like there is no signal being received by the sim and when I tried to activate the UVO service, the screen sat like this for 5 mins before I gave in and turned the car off. Will have to contact the dealer I suspect.

Computer Personal computer Netbook Output device Tablet computer


Gadget Font Communication Device Display device Electronic device
 

Attachments

·
Super Moderator
Niro 2020 HEV 4
Joined
·
6,876 Posts
When you say UVO, have you updated your phone app to Connect?

Try resetting head unit using the pin hole next to volume knob. That tends to force a mobile connection.


 

·
Registered
Joined
·
838 Posts
I agree with @iooi.

A ‘soft’ reset like that normally wakes up the SIM and it makes contact once more, plus it doesn’t change any of your settings.

Plus the UVO app has been discontinued and replaced by Kia Connect. If you haven’t already done so you will need to delete the UVO app from your phone and install the Kia Connect app, same login details


Sent from my iPad using Tapatalk
 

·
Registered
2021 XCeed 3 1.6 CRDI Phantom Black
Joined
·
22 Posts
Discussion Starter · #5 ·
Thanks @iooi and @Alanw47 for your replies.

I didn't know that Kia Connect had replaced the UVO app, I had been using the red logo version (iOS) which had replaced the white logo version. The white one told me it was out of date but the red one had said nothing which is odd. Anyway, downloaded Kia Connect and got connection back with the car and tonight did a soft reset on the head unit and the data reappeared on the sim. Will send a route in the morning to confirm it's working but thanks again.
 

·
Super Moderator
Niro 2020 HEV 4
Joined
·
6,876 Posts
Hope it works, as IOS version is seeing a lot of complaints on e-niro facebook page.
 
  • Wow
Reactions: macgd016
1 - 7 of 7 Posts
Top