Kia Owners Club Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all,
I gave my Sedona a service at the weekend (oil, oil filter, air filter & fuel filter); I've done plenty before but this was the first time on this car.

After the service it's running really rough when idling, the idle speed seems fine but there's a really harsh vibration. There's no warning lights on the dash, I've checked, double checked and triple checked the oil level and it's fine, at first I thought there might be air in the fuel line but I've taken her out on a spin which should have cleared it, engine mounts seem to be OK (hard to tell though) but they shouldn't have been disturbed anyway.

Has anyone experienced anything similar or know what could be wrong?

Thanks in advance.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Hi,It turned out to be a broken engine mount; the 2 bolts on the drivers side top mount had sheared off (must have been when I jacked the car up but never heard of this happening before).
Unfortunately, Kia don't sell the bolts separately and want £70 for a new mount!!! I'm trying to source them from a scrapyard now.
 

·
Registered
Joined
·
141 Posts
sedona gary will have all the parts you need give himm a call he is very help full and parts are posted to you very quickly.



call Gary On 07799 408459 or email [email protected]
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Thanks DMC, Gary had the parts, still have to buy the whole mount but it's a lot cheaper than Kia were charging - I can put the parts I don't need on eBay anyway!!!Just waiting for them to arrive now.
 

·
Registered
Joined
·
702 Posts
elmo said:
Thanks DMC, Gary had the parts, still have to buy the whole mount but it's a lot cheaper than Kia were charging - I can put the parts I don't need on eBay anyway!!!Just waiting for them to arrive now.
Hi
Just seen this thread after returning from holiday and catching up, if I had seen it earlier I could have saved you some money as I have numerous bolts etc left over from various parts of the engine bay including the drivers side engine mount sorry again.
 
1 - 6 of 6 Posts
Top