Kia Owners Club Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi all.
Just bought a 2004 2.9 auto diesel.

Just has a tow bar fitted for towing our caravan, also hada major service just done to be sure.



Problem is, I have a rubbing sort of sound comming from I beleive the front n/s wheel. Garage has looked at it and beleives it is not the wheel bearing as it does not make the noise when on the ramp etc. It only starts at speads above 20mph. I have changed all the wheels round (front to back and back to front) in case it was a tyre noise.....nope.



Going to have 2 new tyres fitted in the morning to see if that cures the problem as two tyres have a slight wear on the inside.



Has anyone else had this problem, or does anyone know what else it might be? Any help would be appreciated.



After spending all this money on it also, the Mrs tells me she is not sure she will be able to drive it as it is "too big!". Great, spend a fortune getting it right and might still have to sell!!!!!!.



Anyway, keeping it or having to sell I will still need to sort out the rubbing sound out.



Thanks.

Brian.
 

·
Registered
Joined
·
192 Posts
hows the brakes do they pull either way or jack it up and spin the wheels one at a time and listen or try and move the wheels top to bottom and check for play check calipers too ,cant be much to worry about
bud good luck.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
corcaighbhoy said:
hows the brakes do they pull either way or jack it up and spin the wheels one at a time and listen or try and move the wheels top to bottom and check for play check calipers too ,cant be much to worry about
bud good luck.


They done all that !


Just had new front disc's and pad's fitted also as they were wearing low.

Will get the front tyres replaced in the morning and see how it goes.



Fingers crossed it works and the Mrs get's on with it !!

 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
Right, 2 new goodyears tyres on the front, no change!
Not the drive shafts or the gearbox (beleived).



It was doing it when I took a left hand bend, now does it when I take a right hand bend!!!!

I still think it must be the tyres as they have all be changed around so many times, front to back and left to right etc. Also now sounds like it it comming from the back!

Think last thing to try is some new tyres on the rear also.



More money, but if it does the job......Great!

Will update as and when I get the tyres on it.

Cheers for help anyway.

 

·
Registered
Joined
·
82 Posts
Mine did this. Turned out to be the back plates touching the disc after they had warped. Back plates are very close on sedonas for some reason. Bent them back by a few mill, all is well.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #11
I would have hoped so !


The brakes are sqeeking a tad at the moment so I shall pop it back to the garage and ask them to look at that also, thanks for the info, again I will keep the site updated.



Apart from that, I am well happy with the car. I am getting the caravan out this weekend to test the electrics etc. I shall go for a quick drive with the caravan on the back also to see what it tows like.



On that note, as the car is very wide, wider than my old merc I used to tow with, do any of you guys that tow have to still use extra mirrors, orcan you see down the side of the van without them?



Cheers.
 
1 - 12 of 12 Posts
Top