Kia Owners Club Forum banner

1 - 20 of 29 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi there. This is my first post here. I have a 56 plate Picanto and it will not start. It is a 1.1 petrol. There is no spark and there is no fuel (Fuel pump under rear seat does not prime when ignition on). Also there is no engine check light nor no immobiliser light coming on at all even on ignition or when kranking. I put a diagnostic machine on it and i cannot read the ecu at all. Tried all protocols though EOBD and also through KIA OBD1. I dont know if this is because the engine ecu is faulty and not reading it or it is because the immobiliser is faulty and not unlocking the engine ecu. Maybe i am reading too much into it. Is this common on these cars. Any help would be great. Should also mention.


1. Car has not started from Friday Night (Xmas Eve) till i tried it today ( 4 Days in bad weather).

2. I tried the spare key just incase the key was faulty (no change, still same fault).

3. Battery has plenty of power. Was not flat at any time.



Hope i covered everything here.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Thanks for the welcome. Was hoping to get it done out with the dealer TBH. Is this comnmon on the picantos do you know. No Immob light and no ECU light on dash at the same time.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Ok will do. Would that be the ones under the bonnet or in the dash. Under the bonnet i would think and the big ones at that.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
Tried the spare as described in my first post but still no joy. it is the no mil light or immob light coming on that is bothering me
 

·
Registered
Joined
·
682 Posts
Hi L&N I think it maybe down to checking the connections on the ECU to see if it has power and what inputs?
Need to talk to owners of Picantos or a tecki who has wiring diagrams, pin numbers and locationsw of units.



Bob
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
That is a good idea. If anybody has a diagram for this i would be greatful. I should say i am a car mechanic and electrician so i can do this myself if had the correct diagram. What gets me is it drove everyday no bother then was off the road for 3 days then this. Very strange i think. Wondering if it could be dampness in the ecu somewhere.
 

·
Registered
Joined
·
14 Posts
mate change your 10amp fuse for the fuel pump It cost me £146 to tow and repair and the 10Amp fuel pump fuse keeps blowing I now have a handful in the glove box as kia reckon its a common problem. I have a 58 plate picanto chill high mileage as it used for deliveries.ps fuses are about 30pence.



Edited by: norris
 

·
Registered
Joined
·
14 Posts
Yes.
please see note from (too Old) He recons the reason the 10amp fuse keep blowing due to a common fault with fuel pump and it will eventually need replacing.
Mine has two months on warrenty so I will be able to get this done soon.
I had placed a message on main notice board under picanto electric.
Good luck
 

·
Registered
Joined
·
2,252 Posts
Cheers Dan. People like that just ruin forums. Seen it with other forums and it ends up just full of bad language and aggressive behaviour.
 
1 - 20 of 29 Posts
Top