Kia Owners Club Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
This code refers to the EGR valve and its performance. On the code reader it refers to 'A'control circuit.
Does anybody know which connector within the electrical plug should show what valve when tested with a multi meter? Does anybody have a wiring diagram?
Thanks in advance.
 

·
Registered
Joined
·
213 Posts
Welcome to the forum.
You could try the search (middle top) there are a fair few posts on here discussing that code below is 26 pages of light reading.

It is mentioned anything from water level top-up to fuel filter change to dodgy supermarket fuel (again). You will have to wade past the nonsense that sometimes prevails.

It is also best to mention your vehicle type, engine, manual auto, etc, as this can affect the answer.
Also, ODB readers if that is what you have used can be fooled into presenting incorrect codes.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Thank you ray_b.. I will endeavour to try reading through suggested posts.
Have used two different obd readers which give same fault code and as I have already changed the EGR valve on suspicion that the solenoid was failing it would now point to wiring as fault occurring more frequently. Hence request for info on wiring diagram if available.
I am aware that another sensor could cause the fault but without being more certain I'm reluctant to perdue that option until I can eliminate the wiring.

It's a 2ltr manual Sportage cdti.

Again thank you for your advise 👍
 

·
Registered
Joined
·
213 Posts
Yes, you are correct that is part of the problem, the States seem to have a bit more information, or at least more free with it, but immission control systems may well differ.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Just an update on the P0404 fault on a 2012 Sportage 2ltr cdti.
The engine light would come on and apart from a loss of power and maximum engine speed of 3000rpm, there were no other symptoms.
The EGR valve was changed (Solenoid was failing) but the fault would keep reoccurring every few days.
The solution was to have the vehicle ECU reset to accept the new valve.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top