Kia Owners Club Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi guys,i'm new on here and need some help.I recently bought a 51 plate 2.9TD.93k FSH and a very very clean car.I love it as it ticks all the boxes,it carries loads of stuff and kids and tows my car trailer with ease.BUT it has started to run very hot / almost overheat.But the temprature always comes down again.It happens everytime i drive it.I've had it checked by 2 garages who have plugged it into diagnostics and found nothing.Its had chemical tests for head gasket failure and all is well.It does blow some water from the overflow on the expansion tank but the engine purrs and there is no smoke at all from the exhaust.I've replaced the thermostat to no avail

The fact that the temprature fluctuates and always goes down before it goes up again leads me to believe its not the head gasket as if it was gone then the temp would keep rising and eventually cook the engine.
So,have i missed something ? is there a known blip thats causing this ? can anyone help and shed some light on this problem
 

·
Registered
Joined
·
702 Posts
chancenellie said:
Hi guys,i'm new on here and need some help.I recently bought a 51 plate 2.9TD.93k FSH and a very very clean car.I love it as it ticks all the boxes,it carries loads of stuff and kids and tows my car trailer with ease.BUT it has started to run very hot / almost overheat.But the temprature always comes down again.It happens everytime i drive it.I've had it checked by 2 garages who have plugged it into diagnostics and found nothing.Its had chemical tests for head gasket failure and all is well.It does blow some water from the overflow on the expansion tank but the engine purrs and there is no smoke at all from the exhaust.I've replaced the thermostat to no avail

The fact that the temprature fluctuates and always goes down before it goes up again leads me to believe its not the head gasket as if it was gone then the temp would keep rising and eventually cook the engine.
So,have i missed something ? is there a known blip thats causing this ? can anyone help and shed some light on this problem

Sounds as though you have an airlock somewhere. Its normally the back heater pipes where the air gets stuck
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hi,thanks for the reply,an air lock is something i had considered,is there any way of bleeding the water system on these engines ?
 

·
Registered
Joined
·
887 Posts
If the system is pressuring then theres only a few things it can be:
Head gasket/head fault, doesn't always show on a chemical test on sedonas.
Radiator blocked (most likely imho)
Thermostat faulty.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I've replaced the thermostat today,which made it better.I have just been out to it and noticed that the heater vent in the rear of the car is blowing cold when the front is blowing hot.Also the heater gets hotter instantly when you rev the engine ?????????
 

·
Registered
Joined
·
422 Posts
Sounds more like air trapped in cooling system - try letting it run on tickover, without the filler cap on,until it comes up to temperature - give it some revs and see if it purges the air out - you may have to keep topping up the water - you'll hear it gurgling out if successful.
 
1 - 7 of 7 Posts
Top