Kia Owners Club Forum banner
1 - 5 of 5 Posts

Registered
Joined
2 Posts
Discussion Starter · #1 ·
Hi I have an 65 Optima and the windscreen washers have failed. The headlamp washer is Ok and the water in the feed pipe from the pump is fine just as the pipe
disappears into the bulkhead and then to the twin jets. I have used a pin to check if the jets are clear so I need to find out if there is rubbish in the jet holder or tube from the bulkhead to the jets. The jets sit on a small pillar which looks if the jet could prized off. Although six years old I have never had this problem before

Regards

Jim.
 

Registered
Joined
3,009 Posts
Although six years old I have never had this problem before
Welcome to the forum, 'Medion1619'.

At six years old, you shouldn't be messing around with stuff like that. Best leave it to your Dad or the local garage! 馃榿

Seriously, I have a later model Optima and have never had any problem with screen washers so I have never looked at the arrangement and can't voice an opinion on the ease or difficulty of jet replacement, should that be necessary. It might be worthwhile researching the jets to see if they can be purchased for reasonable cost. I expect if you were to ask your local KIA dealer to sort it, they would charge an arm and a leg.
 

Registered
Joined
118 Posts
I have a 17 Optima GT Line S and the same happened to mine, you could hear the jets working but no water coming out. Turned out to be rubbish/sediment of some sort in the reservoir, sorted by the garage but wasn't cheap.馃槺

Funnily enough or not when the bill comes in but the same has happened to my wife's 11 Picanto. 馃槙
 

Registered
Kia Niro 3 PHEV (70-plate) Horizon Blue
Joined
4,008 Posts
I have a 17 Optima GT Line S and the same happened to mine, you could hear the jets working but no water coming out. Turned out to be rubbish/sediment of some sort in the reservoir, sorted by the garage but wasn't cheap.馃槺

Funnily enough or not when the bill comes in but the same has happened to my wife's 11 Picanto. 馃槙
My wifes Picanto had the same problem - blocked windscreen jets. The dealer couldn't clear them so replaced the whole panel (that carry the jets) under warranty. Semms this oroblem is usually caused by mixing brands of washer fluid - there is a reaction that causes the formation of a gel.
 

Registered
Joined
118 Posts
My wifes Picanto had the same problem - blocked windscreen jets. The dealer couldn't clear them so replaced the whole panel (that carry the jets) under warranty. Semms this oroblem is usually caused by mixing brands of washer fluid - there is a reaction that causes the formation of a gel.
We don't use washer fluid and sadly my wife's 2011 Picanto is just out of warranty;)
 
1 - 5 of 5 Posts
Top