Kia Owners Club Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I switched to the engineers’ position in my car screen, which is a Kia Optima 2018, and clicked update via USB, and I did not have an update, and this is what happened. Can you help me solve the problem
 

Attachments

·
Super Moderator
2020 Sportage GT-Line CRDi
Joined
·
2,708 Posts
Have you tried switching the main fuse switch, it is usually in the fuse box next to the driver. If you switch it off it drops power to most the accessories and things like central door locking, so you need to stay with the car. Leave it for 15 minutes and then switch it on. With luck it will reset your head unit, otherwise you may need to visit a Kia dealer.
 

·
Super Moderator
2020 Sportage GT-Line CRDi
Joined
·
2,708 Posts
I remembered that somebody else had this problem on the head unit of a Sportage, the thread is here, but it does not make good reading. :unsure:
 

·
Registered
Joined
·
2,730 Posts
it does not make good reading.
It always amazes me when correspondents who post in these pages hoping for advice that may lead to the remedy for a problem they can't sort, refer to interfering with the 'engineering mode' of the infotainment unit.

'137699' expressed a similar sentiment when he responded to the OP in the thread to which you allude in this manner:

You've taken the unit out of the car?
You don't need to take it out to update it....
I'm afraid I don't have much sympathy here. You've been meddling with stuff that you really shouldn't...
 
1 - 5 of 5 Posts
Top