Kia Owners Club Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
For the past couple of weeks the engine management light has been comming on under heavy accel. This has been steadily getting worse (coming on with less heavy accel.) and staying on slightly longer. At the same time i noticed the bus is taking longer to start. Itis now dead on the drive. It took me over an hour to start last night and hasn't wanted to play today.I changed the fuel filter last pm (no metal swarf inside). I have primed the fuel system since on numerous occasions. But it still wont start!
unrelated?

Over the last week i have changed the starter motor (most air pipes and filter housing out)and fixeda fracturedheater wire(post intercooler).
 

·
Registered
Joined
·
662 Posts
ask your dealer to download the fault codes first step also check the egr valve is not jammed open sounds like a pump pressure issue but get the codes first or you will spend a lot of time and money second guessing the issue
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks, I have managed to start it on a couple of occasions and even managed to get it to a friends garage. He downloaded the codes.... or lack of. Its a 53 plate with a standard port in the drivers footwell (that he used and came up with none) and a Kia portunder the bonnet. He questionedif (as its befor 04)the dealers own kit might have codes on it. What is the EGR valve and where is it? I'm also being advised that i could havea problem with air getting in to the pump or fuel lines?
any thoughts?

This is realy starting to cheese me off!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I have checked what i think is the EGR, checked the air pipeto theEGR and the EGR moves when i create a suction. The valve is full seated when nosuction applied.


Still working on it,

if i can get it to start i will take it to the dealer for full diagnostics.
 
1 - 4 of 4 Posts
Top