Kia Owners Club Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I was wondering if anyone had any ideas on the following:

When starting my Rio (1.4 pertrol) there is a high pitched chirp/squeek straight after the engine turns over. It is not a continuous noise and only occurs from cold starts.

any ideas on this?
 

·
Registered
Joined
·
662 Posts
could be the aux belt bedding in some time thease belts have a shine on them and this has to wear off give it a month and see what its like then
 

·
Registered
Joined
·
1,053 Posts
Make sure you make the place you bought it from aware of the problem, even if you're just keeping an eye on it.
 

·
Registered
Joined
·
543 Posts
Are you sure it's not a seagull living under your bonnet lmao
Defently alternator belt mine has same issue still has , been tightened nothing to worry about won't do any harm but get garage to take a looksy .
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
haha, I dare open the bonnet if there is a seagull under there.

The sound has now completely gone, wether it just needed wearing in or the fact that is was - 3 overnight and everything tightened up slightly who knows.

The dealers have been great, had it all booked in and they said just to monitor and get back if any problem.

thanks for all your comments
 

·
Registered
Joined
·
2,252 Posts
Wonder if it was condensation sitting on the pulleys or belt and with you starting up it had slipped that way.
 
1 - 12 of 12 Posts
Top