Kia Owners Club Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hello, please can anyone help me. I've still got the problem of not selecting 'low range' on my 57plate Sorento. The low range light flashes but doesn't go permanently on and select low unless the motor is cold. The problem only appears to happen once I've had a drive round the block and it's up to temp, when's it cold it works perfectly. I have tried the connectors under the car, the plugs into the ECU the dash switch, changed the oil with the correct oil. I am now thinking I should try another ECU I don't want to waste money so going for a second hand one would be the best option, problem is finding one with all numbers on the sticker the same.
 

·
Registered
Joined
·
502 Posts
When you select neutral and then low, can you hear the motor moving on the transfer case and then the green light goes solid? someone previous to you may have selected low either while moving or not in neutral..this can easily result in damage to the motor shaft...if the transfer case and oil are cold, it selects easily? will it do this several times? could you try this a number of times and see if it might free it up a bit? I'm thinking do the cheapest things first?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
When you select neutral and then low, can you hear the motor moving on the transfer case and then the green light goes solid? someone previous to you may have selected low either while moving or not in neutral..this can easily result in damage to the motor shaft...if the transfer case and oil are cold, it selects easily? will it do this several times? could you try this a number of times and see if it might free it up a bit? I'm thinking do the cheapest things first?
Thanks very much for your help. When it's cold you can select as my times as you want, even when it's warmed up a bit and moved around, but as soon as you drive round the block it'll stop working again, until it cools off a bit. At first I thought everything I tried had worked, then go for a drive and it doesn't work again. It wasn't what I done that worked it was the time resting while I fiddled about that worked.
 

·
Registered
Joined
·
502 Posts
Well I would think it's either a wire connection/plug, or a dodgy motor/ shaft, or as you say the TCCS controller...wire or motor first, I would have thought?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
Well I would think it's either a wire connection/plug, or a dodgy motor/ shaft, or as you say the TCCS controller...wire or motor first, I would have thought?
I'll keep plodding away. A second hand ECU isn't that expensive and I've found one on ebay with the same numbers embossed on the case and the same main numbers on the sticker. I'm thinking when everything is up to full temp there is a component in the ECU breaking down. It is frustrating, I've even tried swearing at it and that didn't work either. Thanks again.
 

·
Registered
Joined
·
502 Posts
Page 85 of the diagram says that the shift motor cannot be overhauled but I don't know why..perhaps someone will be able to say if they have done this job?
 

·
Registered
Joined
·
502 Posts
Well it would seem to be the easiest option since you just swap them over?..have you gained access to it? and is it in the same place as the one on my '05?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #8
Page 85 of the diagram says that the shift motor cannot be overhauled but I don't know why..perhaps someone will be able to say if they have done this job?
I was wondering about taking the motor of and having a look at it. The job I do involves taking things apart, making new bits and fixing them so I may be able to sort something.
 

·
Registered
Joined
·
502 Posts
I wonder if when it's warm and doesn't work, if you turn the ignition off and then on, would it reboot the controller perhaps?
 

·
Registered
Joined
·
502 Posts
The motor rotates left and right controlled by the position sensors which are then energised by the controller..obviously if you remove the motor and don't put it back exactly, it would damage something?
 
1 - 11 of 11 Posts
Top