Kia Owners Club Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey all, my horns on this car have been the Bain of my existence for about a year as we must have a vehicle inspected prior to getting it tagged and the horn in my 05 Sorento EX didn’t work. I did minor diagnostic (truth be told, mostly looked scenerios up on line ) and consistently the answer was that the clock spring was bad, so… procrastinating and two non registered tickets later I decided to do further prodding. Good news, after running through horn switch, relays and wiring it simply boiled down to the two horns. I really didn’t expect that, as horns don’t often just GO bad, especially two of them, but, in this case they had. I bought a used hi and low off of eBay and this fixed It. Thank god, but the arm/disarm beep still does not function. Again online research brought me to either resetting the fob by pressing and holding the lock/unlock for two seconds, but that didn’t work. Next was the hood switch which ostensibly should be on the passenger side by the headlight but I’m simply not finding any kind of a switch. I would think that if the switch were removed there would at least be wiring. Is the switch in a different place on my car or is it an altogether different Issue? I hope it is an “action that can be done with either the car ignition or fob series. As a whole I’m pretty mechanical so I’m pretty sure this may be in my wheelhouse. Any help would be appreciated. Oh I’m in America so it’s left hand drive. Thanks in advance.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top