Kia Owners Club Forum banner
1 - 20 of 26 Posts

Registered
Joined
6 Posts
Discussion Starter · #1 ·
Hi all, this is my first post and hope someone can help.
I have a new Niro plug-in and love it I do however have a problem - when the cluster dims in the evening my satnav completely loses it and has no idea where it is!! Kia say its a software problem and they are working on a fix but in the meanwhile is there a way of turning the dimmer function off as this seems to be the problem??
 

Registered
MY21 Stonic GT-Line S ISG MHEV iMT - sw220211 - map14.47.48.631.401.5
Joined
581 Posts
Thanks, but at the moment I have no satnav when I most need it.
There鈥檚 a post from someone else with a similar problem: when using satnav at night, satnav places the car 10 miles from where it actually is.
If you do a search in this forum you should find that post. Hopefully it鈥檚 the same problem and the same fix.
 

Registered
Joined
6 Posts
Discussion Starter · #5 ·
There鈥檚 a post from someone else with a similar problem: when using satnav at night, satnav places the car 10 miles from where it actually is.
If you do a search in this forum you should find that post. Hopefully it鈥檚 the same problem and the same fix.
Thanks will see if I can find it
 

Registered
Joined
21 Posts
Hi, got exactly the same problem on my 21 plate niro 3. Pretty much fine during the day but mainly only noticed the problem in the evening. Annoyingly l thought l would try and use Android auto but realised that is simply uses the GPS from the car so was also 'lost'. Unplugging the phone and using it standalone worked fine, but a little disappointing as l was hoping to have to stop doing that....

Would be good to hear if others also notice the problem and so Kia push to get a fix available as it's a real pain...

Note my software is the purple looking icon one. Also noticed now and again a full reset using a paperclip on the button under volume seems to sort it out for a min or so, then it goes drifting again.
 

Registered
Joined
309 Posts
Just a thought ... where you live, are you far away from any roads that are mapped on the Satnav? I ask this because, to a degree, the Satnav will "snap" your position to the nearest available road. In my case, even though I live on a mapped road, if I park my car far enough up my driveway, which isn't that long, honest!, it sometimes puts me parked up around the corner from my house.

When this happens, take a look at the raw GPS satellite position by going to Setup > Navigation > Automated features >Satellite. You'll see the position in dd mm ss notation. Enter this into Google maps (you can omit the deg, min and sec symbols, but don't forget the N and W) and see where it puts you.

If it locates you at your house then you're fine, it's just the "snap to road" feature playing tricks, if not then I'm seriously puzzled. Bad satellite reception, either due to an unlucky constellation at that particular time and place or due to cutoff from buildings etc. would cause inaccuracies but not something as bad as 10 miles. Other possibilities could maybe be some source of RF interference that only happens at night where you are, security lights can sometimes be a culprit here. You can see a depiction of what satellites it can see on the same screen which can give an indication of what degree of accuracy you can expect. This will vary with time, but if you see a marked drop off in the number of satellites at night time compared to day time it could also maybe point to a local interference problem.
 

Registered
Joined
21 Posts
So l tried some tests on driving around today to confirm some talk seen in other posts.

In short, l tried to see if there was any correlation between the sat nav drifting when in night mode or day mode by covering the light sensor on the middle of the dash near the windscreen.

When the sat nav was in day mode, no issues and everything worked fine.

Cover the light sensor so the unit thinks it's night time and within a minute or so, it's not calculating my position correctly.

Remove the card off the light sensor, sat nav goes back to day mode and after a min or so, my correct position is mapped again !

Tried this a few times just to confirm and pattern is clear.

Seems like a software issue as opposed to hardware l think....
 

Registered
MY21 Stonic GT-Line S ISG MHEV iMT - sw220211 - map14.47.48.631.401.5
Joined
581 Posts
How did you deduct software instead of hardware?
Imagine this: when the sensor is covered, the signal goes HIGH. The pin on the head unit board has a defective solder joint. It now triggered another pin to read HIGH.

it could be software, it could be hardware.
 
  • Like
Reactions: Radiorail

Registered
Stonic 1st Edition
Joined
1,471 Posts
How did you deduct software instead of hardware?
Imagine this: when the sensor is covered, the signal goes HIGH. The pin on the head unit board has a defective solder joint. It now triggered another pin to read HIGH.

it could be software, it could be hardware.
Not to mention interference caused by the electronics that govern Day/Night switching upsetting the GPS decoding.

Irrespective this should not happen and as you can demonstrate the problem it's off to the dealer I think.
 
  • Like
Reactions: Alanw47

Registered
Joined
6 Posts
Discussion Starter · #11 ·
All interesting, I have been to my dealer and they have raised the issue with Kia. Turns out the service managers niro and their courtesy niro both have to the same problem! Awaiting some results.
 

Registered
Joined
21 Posts
So l managed to update the software/maps yesterday and had a good 45min journey this evening back home in the dark on roads l was getting GPS mapping correctly and looks like no drifting happened for the entire journey which is a great sign. As you can imagine a couple of gremlins in the new software that l think l have seen in other threads such as Android auto seemed to have disconnected once and the other thing l noticed as the speed limit sign sometimes didn't show the speed limit of the road l was on and just showed ---. A reset of the headunit using the little button near the volume fixed that on each occasion.

Will see how it goes but hopefully/fingers crossed a positive sign of a fix...
 

Registered
Joined
6 Posts
Discussion Starter · #13 ·
So l managed to update the software/maps yesterday and had a good 45min journey this evening back home in the dark on roads l was getting GPS mapping correctly and looks like no drifting happened for the entire journey which is a great sign. As you can imagine a couple of gremlins in the new software that l think l have seen in other threads such as Android auto seemed to have disconnected once and the other thing l noticed as the speed limit sign sometimes didn't show the speed limit of the road l was on and just showed ---. A reset of the headunit using the little button near the volume fixed that on each occasion.

Will see how it goes but hopefully/fingers crossed a positive sign of a fix...
Sounds good, can you help a newbie - was the update done by your dealer or if not how and where do I get it please.
 

Registered
MY21 Stonic GT-Line S ISG MHEV iMT - sw220211 - map14.47.48.631.401.5
Joined
581 Posts
Sounds good, can you help a newbie - was the update done by your dealer or if not how and where do I get it please.
On the owners area of the UK Kia website Kia.com it mentions the update is now available as a download.
 

Registered
Joined
200 Posts
I have just tried the updating process for my 2019 HEV but struggled a bit.
I went onto their customer live chat and they told me there is no update yet for a 2019 HEV!!
Are they trying to say there have been no map changes since 2019? I find that hard to believe.
 

Super Moderator
Joined
9,401 Posts
Someone is not telling the truth.
As there are at least 1 map update a year & there has been at least 2 this year.

Can I sak you to check your MY year against this list, as it is possible that you have a MY18. (y)

 

Registered
Stonic 1st Edition
Joined
1,471 Posts
I have just tried the updating process for my 2019 HEV but struggled a bit.
I went onto their customer live chat and they told me there is no update yet for a 2019 HEV!!
Are they trying to say there have been no map changes since 2019? I find that hard to believe.
A possible explanation is that the DIY updates do more than just update the map data. They also update and change the user interface and the interaction with other car components. Thus while there is a set of updated map data (which is probably the same for every car) the associated, and linked, files, changing the user interface and Nav unit firmware, has not yet been developed/released for your car.

Unfortunately the way the Nav system has changed over the years seems to make it impossible for the map data to be transferred between different SW versions i.e. it is more than just the road coordinates and junction information.
 

Registered
Joined
200 Posts
iooi asks: "Can I sak you to check your MY year against this list, as it is possible that you have a MY18. (y)"

My 10th digit is 'L' I now see it is MY20
 
  • Like
Reactions: iooi

Registered
Joined
1 Posts
We have a 20 plate Niro PHEV bought August 2021. Since then the satnav has never worked at night, useless when away from home. We live near the coast and it frequently shows us out in the English Channel! We have had a software upgrade at the dealership (now purple screen), which didn鈥檛 work. The antenna has also been replaced, this hasn鈥檛 made any difference either. Any useful suggestions?
 
1 - 20 of 26 Posts
Top