Kia Owners Club Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi there just wanted to say Hi to ALL Kia owners. It's our first experiance as KIA owners as we have just replaced our little Freelander.Our new Kia isa New Sportage 1st Edt. Had the car for approx 2 weeks and we love it. Great drive / car but I have noticed that the car dosn't like stop start in traffic thus problems with the clutch pedlel sticking down plus I've also noticed that the HSC (hill start) isn't working?Is anyone else having teething problems? Our Dealer has beenhelpful and the car was off the road a couple of days having to replace the slave cylinder which has helped but the car only had 13 miles on the clock?
Hope to hear from you soon



BigWeb
 

·
Registered
Joined
·
682 Posts
HiBigWeb and welcome, not a good start for you, hope the KIA tech's get it sorted for you quickly.
Have auto so not had any problem with my model.



Bob
 

·
Registered
Joined
·
112 Posts
Hi Bigweb, I just got a lovely black kia sportage 1st ed on wed-my HAC also doesn't work so will probably have to take it back to the dealer. Perhaps I don't have it switched on or something. Will let you know how I get on. Cheers Johnathan
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Thanks for the feedback, I spoke with the dealer yesterday and he really didn't know if it had a switch or not, so I read the lines from the manual which inducates no switch is involved. You need the car in 1st gear, foot on the clutch and when your foot moves away from the brake it will / should hold the car for 2sec. My gut feeling is that even though it is mentioned in the brouchures it's not fitted to the car? The dealer has another Sportage coming in over the weekend and he's going to get his tech staff to have a look and respond back to me. I'll keep you posted.


Thanks again



The BigWebs
 

·
Registered
Joined
·
70 Posts
Guys, I don't have my sportage yet so can't comment about how it works, but I do remember reading somewhere (wish I could remember where) about someone saying that the hill start assist on the ix35 (which presumably shares electrics) only works on reasonably steep gradients. There must be some switch somewhere which knows if you are facing uphill or not, and it needs to be over a certain amount to activate?

It might be worth testing it on a steeper gradient? If it still doesn't work then I'd definitely say take it back to the dealer...

J.
 

·
Registered
Joined
·
112 Posts
Hi Guys, I'll have to try my Sportage on a steeper gradient then. I did phone the dealer but spoke to someone different who asked me to try the following- when on a hill with handbrake on and ready to go, take handbrake off(obviously) then depress brake pedal and when you take your foot off the brake pedal it should hold-haven't tried it yet but will tomorrow am. Also will give a more indepth briefing when I travel from my home(just outside Hillsborough,Co.Down) down to South Dublin,a round trip of about 200mls-can't wait-cheaper diesel down there also. Cheers guys Johnathan
 
1 - 7 of 7 Posts
Top