Kia Owners Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
my kia sportage 2003 2l petrol, has recently been fitted with a new clutch and new slave cylinder by a mechanic doinga wee homer, but as he gave me it back, on the road home,i broke down, with a puddle or rather a lake of water in my passenger footwell and smoke bellowing through my heater system!!!!


any ideas what may have caused this???? the guy has taken it back to try fix the problem as it was fine before these were fitted!



any advice or ideas given would be muchly appreciated!!!
 

·
Registered
Joined
·
2,252 Posts
He's probably snagged a heater hose when taking gearbox off. The engine may have tilted back and punctured a hose.
As long as he is offering to rectify it then you shouldnt worry.

Hope it comes good in the end Koolkes.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
thanks for replying davy!


he said it was my heater matrix that had went, so he is fixing it for me!!!

was totally panicking as he couldnt get a look at it untill later on the next day, so i was thinking the worst!!! but im a happy bunny now!!!



if its ok can i run something by you if you have any ideas.....before i pester my poor mechanic again, my four wheel drive only seems to be engaging my rear wheels and not my front is this a common fault in kias?? or am i being sily?? lol
 

·
Registered
Joined
·
144 Posts
Is your Sportage an Automatic or manual transaxle? Automatic ones push the power where it is needed, not always where you expect it to be!


Manual transaxles will usually drive the rear wheels in 2H and all four in 4H and 4Low. Dont know for certain with regards to sportage, dont even know what an 03 sportage should look like. Is it the first of the newer shape or the last of the old?
 

·
Registered
Joined
·
887 Posts
2003 sportage is the old shape, if front wheel aren't engaging in 4H, then I'd lay a small bet your vac pipes to front hubs are split.
 
1 - 5 of 5 Posts
Top