Kia Owners Club Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a '16 Sorento with 64k miles.
I got the above error today while My wife and I are going off on a short vacation and updating software never once crossed my mind.
I am currently around 190 miles from home and the error pop'd up when the car was restarted after a 10 minute break in the trip. He'll I don't even know where to put a sd card into the dash
I am the original owner and have never updated this car.
Can anyone shed light on this mysterious and failed update?
 

·
Registered
Joined
·
7 Posts
Could be a faulty SD card, or a bad connection. If you have never updated the software, why is it mysterious and failed? The SD card slot is to the right of the CD slot and has SD printed on it. With the engine switched off, remove the SD card and gently wipe the contacts with a clean dry cloth, replace and see how you get on.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Hi & Welcome

Why is the SD card not in the dash?

They need to be left in all the time as the maps are stored on them.
The sd card was and always has been in the proper slot. My point was that it has never been removed and for it to suddenly fail during a trip, with navigation on, is very strange. Suggests a failure of the navigation system itself.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Could be a faulty SD card, or a bad connection. If you have never updated the software, why is it mysterious and failed? The SD card slot is to the right of the CD slot and has SD printed on it. With the engine switched off, remove the SD card and gently wipe the contacts with a clean dry cloth, replace and see how you get on.
You are suggesting there is a drop dead date on the software? Mid-trip? If that were the case I would expect it to happen at 1 second after midnight. Even then I am only 8 hours off of GMT.
I've never bothered with it and now it appears I have to, but that'll need to wait till I return home and access to my PC and burn an updated card.
Thank you for the input.
 

·
Registered
Joined
·
7 Posts
I'm suggesting that the navigation system can't read the SD card which is what usually happens when the system can't initialise. I have given you a reasonable solution to your problem. I now believe that you think that the software is updated over the internet or by some other means in an automatic fashion, It's updated when YOU decide to update it manually. It's not automatic and will need to be done with some experience or knowledge of the process. I'm not sure where the reference to GMT comes from or the fact that the software should know that you are on a trip. If you believe it's the head unit, buy all means ignore my suggestion and buty a replacement. I was only making a cheap, easy and simple suggestion to your issue. Good luck.
 

·
Super Moderator
Joined
·
10,005 Posts
The sd card was and always has been in the proper slot. My point was that it has never been removed and for it to suddenly fail during a trip, with navigation on, is very strange. Suggests a failure of the navigation system itself.
Far more likely that SD card failed than infotainment unit. As like any other electrical equipment can fail at any point.

Is it really hot where you are at the moment?

I would try @technosplash idea of taking SD card out give the contacts a clean to see if that will help. If not then sounds like card has simply failed.
 
1 - 7 of 7 Posts
Top