Kia Owners Club Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi there I hope someone can help as I am struggling to get my trusty 2004 sorento to start. It started taking longer cranking time to start so i changed the fuel filter hoping it was just a case of a dirty filter (it was less than 12 months and 8k miles old). since then i have replaced 3 dead glow plugs the leak off pipes and the crank sensor. the fuel pressure is 110 Bar when cranking and the immobiliser light comes on when you turn the ignition on. has anyone got any ideas as i really dont want to have to replace it. I am reluctant to try easy start as i know it can cause lasting damage.
 

·
Registered
Joined
·
3,413 Posts
with common rail on these the fuel pressure should be up over 1000 bar, with most common rail systems there has to be a minimum fuel pressure generated at cranking speed, if this minimum is not reached injection pulses are disabled, you need to make sure the system is bled then do a leak off test on the injectors.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I drove if 60 miles since i changed the leak off pipes and filter so i hope it is bled properly by now?
 

·
Registered
Joined
·
3,413 Posts
you need to remove the leak off pipes and fit a bottle to each injector leak off nipple. you crank it over for a while and monitor how much fuel is in each bottle. if you have some that has a lot of fuel in it the injector will be passing too much fuel via the leak off rail, dumping the fuel pressure,
 
1 - 6 of 6 Posts
Top