Kia Owners Club Forum banner
1 - 17 of 17 Posts

Registered
Joined
7 Posts
Discussion Starter · #1 ·
I have paired my android phone successfully, I have downloaded Android Auto and I find I can contact the phone via "hey, Google". All well and good. BUT my Niro Hybrid always displays the message, "Failed to download contacts." What makes it even worse is that I get this message whenever I start the car!
1. Can anyone help with the contacts failure (and yes, sharing of contacts is enabled on Android Auto)?
2. If not, how can I stop the message appearing all the time?

Thanks in hopeful anticipation.
 

Super Moderator
Joined
5,978 Posts
Hi & Welcome

Delete phone & car from car/phone setup & start again.
Mine does it from time to time. Not done it for a long time, but then again mine is usually connected via cable.
 

Registered
Joined
7 Posts
Discussion Starter · #3 ·
Hi & Welcome

Delete phone & car from car/phone setup & start again.
Mine does it from time to time. Not done it for a long time, but then again mine is usually connected via cable.
Thanks for the suggestions. I'll give it a try tomorrow. It has happened plugged in or not plugged in, but I'll give it a go.
 

Super Moderator
2020 Sportage GT-Line CRDi
Joined
2,065 Posts
On your telephone go into Settings > Connection > Bluetooth. On mine it lists Paired Devices and next to Kia Motors (yours may be named something else) there is a cog icon, click on that and you have option to use for Calls, Audio and Contact access. Enable Contact access and see if that does the trick.
 

Registered
Joined
7 Posts
Discussion Starter · #5 ·
On your telephone go into Settings > Connection > Bluetooth. On mine it lists Paired Devices and next to Kia Motors (yours may be named something else) there is a cog icon, click on that and you have option to use for Calls, Audio and Contact access. Enable Contact access and see if that does the trick.
I've had this advice before; unfortunately I can't do that. When I go to the Kia bluetooth connection and press the cog icon, very briefly the is a share contacts option, but it immediately disappears before its possible to do anything.
 

Super Moderator
2020 Sportage GT-Line CRDi
Joined
2,065 Posts
Is that while your phone is connected to your car? If it still doesn't work delete the Bluetooth link on your car and phone then remake it, but as the link is remaking watch out for any messages about contact sharing. I don't think there is one but you never know. You could also try the cog icon after remaking the link.
 

Registered
Joined
231 Posts
On your telephone go into Settings > Connection > Bluetooth. On mine it lists Paired Devices and next to Kia Motors (yours may be named something else) there is a cog icon, click on that and you have option to use for Calls, Audio and Contact access. Enable Contact access and see if that does the trick.
That doesn't work on some phones. (like mine!)
 

Super Moderator
2020 Sportage GT-Line CRDi
Joined
2,065 Posts
That doesn't work on some phones. (like mine!)
I am so sorry to hear that didn't work on your phone, it certainly worked on mine when I had the same problem and I can only pass on what worked for me.
For the record my phone is a Samsung Galaxy J6, running Android 10.
 

Registered
Joined
276 Posts
It is best chnaging the bluetooth settings while not in the car so it isn't trying to connect. Just checked mine and contact sharing was off.
 

Super Moderator
Joined
5,978 Posts
Thanks for all the suggestions, but nothing has worked yet. Perhaps it's the phone.
Which phone, Android Version?

Can you confirm that you are getting the message while connected via cable?
 

Registered
Joined
270 Posts
Mine also gives the same message everytime I get in. I just assumed it was a problem with my phone as I cannot run android Auto on my phone because it is a particular Motarola model, which despite having an up to date version of Android is just not able to operate Android Auto. If I am honest I am not that bothered because I don't own a phone so that I can organise my entire life around it. My phone is also a MotoG5S
 

Registered
Joined
352 Posts
I have a Moto G5, using Android 8.1.0 OS.

The phone connects perfectly with or without a cable giving full access to contacts.

When you are pairing your G5 with your car's bluetooth, there are a set of boxes in your phone's settings (one of which is giving permission to access contacts) which all need to be ticked.

I'm sorry that I can't remember the exact sequence of events, but would suggest you persevere and it will work. Although hang on, just had a quick look on my phone. Go to bluetooth by pulling down from the top of your phone's screen. Click the small down arrow next to the word "bluetooth" and a list of your devices will appear. If your "Kia Motors" is not in the list, press on "More settings". My car is listed there, and if I click on the cog, there are a series of boxes (Phone calls, media sharing, contact sharing, text messages) all of which need to be ticked. I suspect your problem is that the contacts box is not ticked.

Hope this helps
 

Registered
Joined
7 Posts
Discussion Starter · #15 ·
I have just got rid of the Covid-19 ap (which I have suspected interferes with things bluetooth) and tried again. Using the usb cable I now don't get asked for the contacts download and things seem to work OK. If not using the cable it still asks me.
As far as using the Kia bluetooth settings, as I said before, I don't get the option of contact sharing, though I did enable sharing when pairing.
I will continue for a few days trying various combinations of things, but using the cable seems to be the way forward. I wonder whether the Niro hybrid is a bit different in all these respects.
Again, thanks all who have tried to help. I'll update my findings next week some time.
 

Registered
Joined
276 Posts
You should see 3 options in the bluetooth settings as below.

10611
 

Registered
Joined
7 Posts
Discussion Starter · #17 ·
That's not the case for me. Once I have paired the phone (with share contacts ticked at that stage), as explained above, when I go to the screen you show, the third option flashes up VERY briefly and I then only have the first two.
 
1 - 17 of 17 Posts
Top