Kia Owners Club Forum banner
1 - 8 of 8 Posts

Registered
Joined
2 Posts
Discussion Starter · #1 ·
Just been onto the Kia update page and it has May's release. Has anyone installed it yet for compact class generation 5 and is the speed information now working?
 

Super Moderator
Joined
10,059 Posts

Registered
2019 Sportage 2, 1.6 (AWD) , Petrol.
Joined
25 Posts
I hadn鈥檛 updated the software as I was not suffering any of the faults posted on this forum but the map was dated.
I tried using the my present software version for selection in the update software and its not found.
Does that mean:-
1. the updated software is not suitable for my vehicle or
2. just use general Sportage 18.

QL_PE.EUR.SOP.003.30.180703.STD_M
MY2019.
G
 

Registered
Kia Sportage GT Line S 2019 (69 plate)
Joined
876 Posts
I hadn鈥檛 updated the software as I was not suffering any of the faults posted on this forum but the map was dated.
I tried using the my present software version for selection in the update software and its not found.
Does that mean:-
1. the updated software is not suitable for my vehicle or
2. just use general Sportage 18.

QL_PE.EUR.SOP.003.30.180703.STD_M
MY2019.
G
So my car is a 2019 Sportage. It uses MY18 which is sd card standard Gen 5.
Imagine this would be same for you.
 

Registered
2019 Sportage 2, 1.6 (AWD) , Petrol.
Joined
25 Posts
So my car is a 2019 Sportage. It uses MY18 which is sd card standard Gen 5.
Imagine this would be same for you.
Yes. Mine is the sd card standard Gen 5 but last time , using previous Kia update software when I inputted the software version it found the car as a Sportage MY18 but this time the message was 鈥 no item found鈥.
So is the MY18 suitable or is there some reason it shouldn鈥檛 be used?

G
 

Registered
Kia Sportage GT Line S 2019 (69 plate)
Joined
876 Posts
Yes. Mine is the sd card standard Gen 5 but last time , using previous Kia update software when I inputted the software version it found the car as a Sportage MY18 but this time the message was 鈥 no item found鈥.
So is the MY18 suitable or is there some reason it shouldn鈥檛 be used?

G
I never even put the number in this time around. I knew from last time that the software used was gen 5. So I just chose My18 and downloaded the software. All works fine for me.
 

Super Moderator
Joined
10,059 Posts
I hadn鈥檛 updated the software as I was not suffering any of the faults posted on this forum but the map was dated.
I tried using the my present software version for selection in the update software and its not found.
Does that mean:-
1. the updated software is not suitable for my vehicle or
2. just use general Sportage 18.

QL_PE.EUR.SOP.003.30.180703.STD_M
MY2019.
G
Looks like it's the MY18 version. As there is nothing till MY21 & that is for the 10.25 screen.
 
1 - 8 of 8 Posts
Top