Kia Owners Club Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi there,had my07sportage serviced on the 27th march this year and after only 2 weeks of the warranty running out,today(22nd April)i noticedthe malfunction indicator light (the engine logo)came on and stayed on,i've informed the kia dealer in my area,who in turn have booked it in for next week for a diagnostic check.


I told them that none of the other dials have been affected,such as fuel or water temperature(so far!!),so has anybody had the same problem and what was/is the worst case scenario as regarding cost,the gutting part of it all is that my warranty has only expired by only 6 days.



Hope anybody can help....thanks
 

·
Registered
Joined
·
2,252 Posts
It could be a multitude of things wrong. The only way to find out what the problem is is to connect to a diagnostic code reader or take it to a garage who has one. It may be something simple and not expensive to rectify.
 

·
Registered
Joined
·
682 Posts
Hi Murray10, see what the diagnostic shows up, it could be some think was disturbed on the service?
Also you do not show which model you have.



Bob.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Hi Bob,I've got a 07sportage xs 4wd 2.0 ltrcrdi,just got back from doing some shopping and now the car is losing power and then suddenly comes back

I take it in this tuesday,so hopefully (fingers crossed) won't conk out on me.
thank's also Davy for replying to me
 

·
Registered
Joined
·
1 Posts
Hi Murray10. I hope you have had more luck sorting out the problem than I have. I drive an 08 model 2.0D XS. Since Feb 09 to date it has been at my local dealer for 130 days with the engine logo light on. It's had a new engine management unit, various sensors changed andnew wiring looms. I've had it back several times and then it's back in for repairafter a few miles, ranging from 16 -3000 miles. The cars on lease so at least I get a replacement from my lease company, but it's not a good advert for aftercare
 

·
Registered
Joined
·
682 Posts
Hi Murry10 you will notice a loss of power due to ECU going to safe mode.
hopefully you have had it checked on Tuesday, and should have some answers to the problem and had it fixed.

please let us know the out come.



Bob.
 

·
Registered
Joined
·
5 Posts
hi can anyone throw sum light on my problem.


i have a sportage 2.0 xs diesel manual 2006 model. I had service done on it mid feb this year, mot done 3 weeks later. At around this time everytime i came home from shopping and went to the rear to get shopping out i notice a very strong smell (i can only describe this as like the smell you get when behind lorries or buses - like a strong oil burning smell), i only ever noticed it on my shopping day (journey time approx6 miles). I next noticed it when i went on a day trip to chessington world of adventures (approx 18 miles drive), we could smell it coming into the car while the window was open. the following week we went to lego land (approx. 45 miles) at around 5 mins from lego land the engine management light came on, (this was on the saturday), i was having trouble getting a booking to have diagnostics done but on the monday the light had gone of when i first started car up and stayed of until the wednesday when i did another journey of around 45 miles and the last 5 mins again the engine management light came on. finally managed to get a diagnostics done on thefollowing monday(but again by this time the light had gone of - it seemed that if i didnt use the car for around 24 - 48 hrs the light would always go of/reset itself). i was told the diagnostics pointed to faulty EGR valve, i had this replaced (and this was not a kia dealer but independant mechanic recomended by a friend) as i drove the car home i noticed that it seemed to lose power (for a short time) then it would come back again with force, it also had what i would call a cough - like a judder lasting a few seconds but i only notice it in second gear. i immediately went straight back and the mechanic put the diagnostics back on (no codes or anything at all came up), he checked over everything to make sure nothing was out of place and even drove the car, but could not find what was wrong. He said that some of the newer cars today have to be driven for a while for the ECU to reset and recognise it has a new EGR valve, he told me to drive it until after the bank holiday and if it hadnt improved then to go back and he would re-diagnose and also check the new valve to make sure its not faulty. I did this and yes it seemed to get a bit better, some days no problems then others slight as above and sometimes the same as when i collected it. Took it back on the tuesday after bank holiday, valve was taken of and checked, re-diagnosed, fuel filter was checked, but still no reason for this happening. I have taken it to another mechanic, this mechanic drove it to his place of work (nothing happend) he checked everything same as other one did (nothing) but then he found a squashed pipe, which he thinks was done when EGR valve was changed, so he replaced this and went for a drive in car to check but the problem was still there and this was the first time he had felt it. He is now scratching his head. Another mechanic he knows said the ECU may need to be updated, for it to recognise the new EGR valve and to recognise any other faults. Can anyone help with this problem at all? Does anyone know if updating the ECU will do the trick or will it just lead to wasted costs, and more problems? Up until now i have loved this car (had it for just over a year) and now i just want to sell it, especially if no one knows what is up with it and why its doing this. I have noticed also that i seem to be going through diesel more in the last couple of months and im not doing any more driving than i was before, infacet probably doing a bit less driving. i would appreciate any help. thanks
 

·
Registered
Joined
·
5 Posts
oh sorry just to add to my post, the strong smell i describe at the beginning of my post was coming from the exhaust. I probably do around 40 miles in total a week usage wise.
 

·
Registered
Joined
·
682 Posts
Hi Sapphire would be better at starting a new post with this problem.
Its just a suggestion, but because you do very little mileage and short journeys it maybe that it needs a good run to blow out the exshaut system, diesel's engines tend to take longer to warm up and can soot up, which may cause a problem with the cat or some of the sensors.

Also was the fuel filter changed for a KIA original as third party replacements can cause problems.

If you have breakdown cover with one of the main recovery services I would give it a good blowout down the motorway at 60+MPHfor a good hour, at least they will get you home if you have a problem and you should have a fault code.

Areyou using a different fuel brand now?

Hope the above may help you.



Bob.
 

·
Registered
Joined
·
887 Posts
Ok you probably did have a faulty egr valve, but theres several ecu upgrades to go along with egr valve replacement, only a kia dealer can do these.
 

·
Registered
Joined
·
5 Posts
thanks for ur replies. I am using same petrol brand i have always used. And car is going into kia on tuesday. Basicly been told by kia mechanic that it does need ecu update and that this is to stop people goin to any mechanic to get repairs done, and that u only can use maindealer mechanics as this is what will happen everytime any work is done on car.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #12
Hi Bob,sorry for not getting back to you,anyway,the problem has been solved,it was a faulty valve in the exhaust system (i don't know which one),they quoted me £475 for them to do it,i stuck to my guns and said that i wasn't prepared to pay it in principal.


I told them that in light of me paying £700 for a service and mot not 3 weeks earlier,and the fact that the warranty had only run out by only 6 yes 6 days!!,that it wasn't in their interest to charge me,as i was thinking about changing my car.



To be fair the service manager said that he'd contact kia hq,tell them that i'd had kia servicing from day one,and he'd do his best to get it done for free as agoodwill gesture,but couldn't promise anything,and that he'd let me know within 24 hrs.



True to his word he got back to me within 24hrs and told me the news i'd been waiting for.that kia would honour my expired warranty,and so got the work done for free,and it was done in a day.



For once a car company has restored my faith in human nature.thankyou all for your imput and help.

Mike
 

·
Registered
Joined
·
682 Posts
Good resault Murray10

Seems like you have a good centre that looks after their customers.
Many happy miles of motoring.



Bob.
 

·
Registered
Joined
·
192 Posts
was it the gas sensor in the exaust ,and 700 quid for a service, eek thank god i do my own. how can kia justify the price of a service that takes about an hour total rip off. my other cars the same ssangyong musso korean cousin to the kia they wanted 1800 quid to fit a clutch ha ha i burst out laughing the guy told me it s a 12hr labour job ,i done it in 7hrs with a hand from a pal of mine ,most of the korean car companys dont licence there products thats why you cant get the hayes manual for them total joke .
 

·
Registered
Joined
·
2,252 Posts
Its a 5 hour job on the Musso for a clutch. The other 7 hours is smoking, chatting, lookin at girly mags and then off to the bog for a bit of wrist excerciseand then to clean his tools
 

·
Registered
Joined
·
5 Posts
hi just to give the latest on my kia sportage, as said before had EGR valve replaced but then ended up with car running bad, it seemed tohave a kinda cough in second gear, no loss of power just this kinda judda in second gear but not all the time, had diagnostics on it 5+ times and nothing found, had a full service and mot done approx 2 month prior to valve going, mechanic also checked fuel filter to make sure that this wasnt the problem but he said that looked ok. was then told that the cars CPU may need an update, so had this done last tuesday by kia (costing £86) they also done a free overall of the car and checked everything (again they say all is ok and in good condition), but still the car is doing the same thing, this has only happened since having EGR valve replace. I am still using the same fuel, also the car has had sum diesel engine cleaner put into the fuel (i think it was Reddex or somthing) this was done a week before the EGR Valve was replaced. When i explained to kia wat problem i was getting from my car they said the update should fix the problem (i would just like to ad her that it was an idependant mechanic that has a mate that works for kia that told him the car needed the update). Can anyone help at all as i am now stuck and it seems all mechanics are also dumb founded by it....
 

·
Registered
Joined
·
5 Posts
also would just like to say took it on the motorway saturday (as one member suggested may be sooted up) and she goes like a bullet no problems until need to go into second gear then its still there, its like going over rumble strips that are very close together but only last seconds and may not happen again for rest of day but sometimes all the time when seconds selected. weird!!!
 

·
Registered
Joined
·
662 Posts
ok here goes the problem is with the egr heat exchanger you need to unbolt the egr and the heat exchanger then clean all the carbon deposits from the exchanger and refit.
this along with the ecm upgrade should cure your issue. make sure the passageway from the exchanger to head is clear and not full of carbon this issue also affects kia carens models

early 5 speed sportages all had a hesitation usualy first 5 miles in the morning when pulling away in first or second and that was standard
 

·
Registered
Joined
·
9 Posts
hi everyone
i had the engine light come on , and it turned out to be the egr valve a very common fault on the 2.0 diesel crdi engine . cost direct from kia via kia dealer £425 fitted , but hey its all good and works wll , ive had this sportage now for 18 months and no other problems at all





regards

rob
 
1 - 19 of 19 Posts
Top