Kia Owners Club Forum banner

1 - 4 of 4 Posts

Registered
Joined
3 Posts
Discussion Starter · #1 ·
I HAVE HAD THIS 2016 SPORTAGE 4X4 AWD 2 LTR AUTOMATIC FOR 2 YEARS.
IT'S BEEN TROUBLE FREE UP TILL NOW. I HAVE SUDENLY BEEN HAVING A MESSAGE DISPLAYED ON THE SAT NAV SCREEN SAYING MALFUNCTION ERROR, IT FLASHES ON AND OFF. SOME DAYS IT DOSENT DISPLAY AT ALL. EVERY THING WORKS AS IT SHOULD ,RADIO PHONE SAT NAV ALL WORKING AS IT SHOULD.
ANYONE OUT THERE HAVING HAD THE SAME PROBLEM AND HOW DID THEY FIX IT.
 

Super Moderator
Joined
4,312 Posts
Never seen that one before on here, but have you tried a reset?
Usually a small hole under volume button that you can stick something slim it and it will reset it.

Posting in CAPS is considered shouting so is not nice on forums. As well as not as easy to read. :)
 

Registered
Joined
3 Posts
Discussion Starter · #3 ·
Never seen that one before on here, but have you tried a reset?
Usually a small hole under volume button that you can stick something slim it and it will reset it.

Posting in CAPS is considered shouting so is not nice on forums. As well as not as easy to read. :)
oops sorry for shouting, it's stopped for now but it comes back on after a day or so, if it does I'll try the reset button.
I had a software update hopping that would stop it, Kia want me so have a diagnostics test on it for the tune of 拢40 odd.
 

Registered
2020 Sportage GT-Line CRDi
Joined
1,435 Posts
It could be your SD Card is about to fail. It is something they are prone to doing if they are subject to continuous write cycles, for example dash cams. However I wouldn't have thought the sat nav SD card was subject to those types of demands, but you never know. For the cost of a 32GB SD Card it might be worth copying the data across just in case.
Otherwise iooi reset suggestion wouldn't do any harm, although you may have to re-do all Bluetooth/Wi-Fi connections.
 
1 - 4 of 4 Posts
Top