Kia Owners Club Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Took my recently aquired 2003 2.0 crdi on a 150 mile round trip and got a worrying thing happen. I kept losing power on slight inclines plus during my attempts to accellerate i got a vibrating ratterly noise. It would hold same speed or even lose speed then suddenly be okay again.
I will be returning car to place of purchase but would like any pointers.
 

·
Registered
Joined
·
72 Posts
H baz
just a quick one, when was the fuel filter last changed,or the air filter,Also not sure if this model has a sedimentor bowl, sounds like fuel starvation to me

hope this helps

col
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Was meant to have a full service before i picked it up !!!? Also had a service according to service record only 1000 miles ago.
Have rang garage anfd they say they will sort it regardless of anything.
According to manual they do have a sedi bowl.

Thanks for your reply
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Picked it up yesterday after they fitted new fuel filter and put fuel conditioner in it. Was told to give it a couple of days to see how it went. They didn't try it for themselves.
On the way home (40 mile drive) car would not do more than 2500 rpm in any gear. Max speed of 75mph !!! Got home, spoke to manager and told him to come and pick it up and not to bring it back untril it was sorted.
Today i got up off nights to find an Escort in the drive ( courtesy car) and the Carens gone.
Will keep you posted !!!!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Still havent got the car back.
They changed a sensor which sorted the no more than 2500 rpm bit out, but the noise which appeared in 1st and 2nd gear as been refered back to the place that sorted out the non-existant 1st gear when i test drove the car.
I have owned the car 3 weeks and only had it parked at home for 4 days !!!!!!
 
1 - 7 of 7 Posts
Top