Kia Owners Club Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
hi , i have a sportage 2.0 diesel 2005 ,4x4 somtimes it wont start but engine turns over fine battery seems good , if i plug in the obd scanner it says no codes are stored , but if i hit reset a few times it starts and runs great , , now i did have a small problem with the egr valve last year and i suspect the auto electrician reset it and turned off the mill at the same time could this egr valve be causing me the same problem ?

regards
rob
 

·
Registered
Joined
·
682 Posts
Hi Rob
When you say you hit the reset a few times do you mean turning the ignition on, if so it could be you have a problem with one or more of the glow plugs failing?

For what they cost its worth changing them after a couple of years.



Bob.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
hi sorry in the delay getting back to you , i had a issue getting in to my account , all sorted now though , ok , when i posted this the car wouldnt start , the engine management light was off , i used a scanner to check for problems and nothing was stored in the vehicle it said so i pressed erase and hey presto all was good , but that was last year dec 2009 , . went out in car again to day and yep you guessed , wouldn start used scanner to read (nothing )stored again , pressed reset all was good again , this happened four maybe five times today while i was delivering items locally, but also the engine light is on aswell now , im thinking egr valve , as last year it came up with the code for that twice ,


regards



rob

sportage1
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
hi , ive run the scanner and the mil is off , no codes store , it says . it starts fine when cold but when hot doesnt , i either have to try and use scanner to reset , or i have found waiting for it to cool down cures it too , im suspecting the crank sensor after reading up in forums as this little critter seems to have the same symptoms when goins u/s ,
thanks rob
 

·
Registered
Joined
·
682 Posts
Hi Murphwiz would that not show up on a code on his scanner? seems like some think is going bad as it gets hotter? but even that should give him a code to put the MIL on?


Bob.
 
1 - 8 of 8 Posts
Top