Kia Owners Club Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello everyone,
I have a Kia Soul Tempest diesel 1.6. 2010.
Lovely car to drive but I've noticed the accelerator pedal almost feels as if it has a kick-down to it. I know it's impossible for a manual transmission to have a kick-down but that's what it does. The accelerator pedal goes about 80% down then you feel like your at full throttle position, but then push your right foot alittle harder and it jumps down further around 1/2 ". Revs increase but also the cars steering wheel shakes and vibrates hard!
If I drive the kia normal and don't kick-down the pedal it doesn't vibrate. Please note the car does accelerate fine through the gears without kicking down the pedal. (Not the fastest thing in the world though lol) but it's just got me wanting to see what the issue is? Or if anyone please has had the same issue with theirs before?? Any help or advice would be appreciated.


Reply Quote
 

·
Registered
Joined
·
803 Posts
As Steve posted,is the vibration speed or revs related ?
Once you have accelerated up to your max speed and throttle back a bit to 'cruise' at a steady speed - does the vibration disappear ? Or is it related to cruising speed ?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
Sorry I see now. I'd say then it's revs related. Because you could be in 3rd,4th, or 5th cruising speed. And if you were to put your foot completely down to floor past the sticking kick back notion it'll vibrate as if its flooding or stalling
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
As Steve posted,is the vibration speed or revs related ?
Once you have accelerated up to your max speed and throttle back a bit to 'cruise' at a steady speed - does the vibration disappear ? Or is it related to cruising speed ?
Yes once you accelerate fully past the kick down it'll vibrate. If you then ease off accelerator the vibration will disappear.
 

·
Super Moderator
Joined
·
9,472 Posts
Is throttle cable operated?
If so it could either need replacing or lubricating. Also could be that there is a stop on engine end that is not working as it should (lose?) & pressing further pushes it passed the point it should go.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top