Kia Owners Club Forum banner
1 - 16 of 16 Posts

Registered
Joined
13 Posts
Discussion Starter · #1 ·
Hi.
I get the following error when trying to use several functions in the Kia Connect app. I also got the same when using UVO.

"Network error. Please try again later. etc..."''

I understand that some functions are only availabler for full ev's, but I cannot do some simple things like set a profile picture or back up my profile.

I can check the status of my car ok and lock/unlock remotely.

I have enabled all app permissions. I have tried doing it in the car and in my house. Wifi and bluetooth connections are all good.

What else could be causing this issue? Is there a problem with the in-vehicle sim card?
 

Registered
Niro DL, 2020, UVO
Joined
133 Posts
Have you deleted the UVO app from your mobile? If not, please do!
 

Registered
Joined
13 Posts
Discussion Starter · #5 ·
Tried a head reset already. Uvo app deleted and now using KIA Connect with the same result. Some functions (charging status, locate vehicle etc) work ok which seems to rule out a connection issue.
 

Super Moderator
Joined
9,472 Posts
Try going to "Status" & refresh that page to ensure phone connection to servers.
Just managed to back mine up. Strange that it took a couple of seconds to come up with a complete message...
I did find when setting my profile picture that it was very picky on where the picture came from on my phone.
 

Registered
Joined
92 Posts
Try deleting the Connect app from your phone, clearing your cookies on your mobile, then reinstalling the App again from The App Store, assuming you鈥檙e using an iPhone. That should ensure that you won鈥檛 be using any cookies from the old UVO or earlier versions of the Kia Connect App.
The Kia Connect App is notoriously bad and full of glitches, even the latest version.
 

Registered
Joined
13 Posts
Discussion Starter · #8 ·
Thanks for the suggestions guys.
Status refresh works fine - it gives me vehicle location, charge status, lock info etc..Maybe that's all that works???
Uninstalled app, cleared browsing data and cookies on my Android phone and re-installed the app - same result :-(
Going to check my phone number is formatted correctly in the car (saw this on another post) but some functions seem to work so I don't think it's a connection issue with the car.
Maybe my account is screwed - the dealer set it up when when I picked my vehicle up.
I'll contact KIA support and see if they can help.
 

Registered
Joined
13 Posts
Discussion Starter · #10 ·
What vehicle and model are you driving? Some of the functionality is only for pure EV鈥檚 and some plugins. Like remote climate control for example.
Sorento PHEV - I understand the climate stuff is only available on pure EV's - I'm just trying to back up my profile and set a new profile picture.
 

Registered
2021 Sorento 3 HEV
Joined
7 Posts
I have a Sorento HEV and using the Kia connect app. All functionality works fine. The only niggle is the odometer reading says 4500000 miles, yes 4.5 million miles and I only picked the car up new in September!
 

Registered
Joined
13 Posts
Discussion Starter · #16 ·
A quick update - problem fixed with the help of KIA support. Followed the instructions below and all now working correctly.

Thanks for your message.

We're not aware of any issues and it will work for all vehicles. I'd recommend doing the following:

  1. Delete your driver profile in-car from the Profile area of the touchscreen.
  2. Force close your Kia Connect app.
  3. Deactivate UVO/Kia Connect in-car.

Depending on your car's software, you can deactivate via:

Touchscreen main menu > UVO > scroll down > Deactivate or
Touchscreen main menu > Data / Network > UVO settings > Deactivate

  1. Reset your car's touchscreen by inserting the nib of a pen in the pinhole by the volume control.
  2. Once back online and ensuring you have signal bars at the top of the touchscreen, activate UVO/Kia Connect in-car again. Scroll down through the terms and conditions and agree.
  3. Reopen the Kia Connect app and pair it with the car again.
  4. Finally create your driver profile in-car and link to your phone. The mobile number number needs to be entered in-car in +44 format. The + is generated by pressing and holding '0'.

We can then review if you have any more issues.
 
1 - 16 of 16 Posts
Top